Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7610 - knfsd will not restart after stopped
Summary: knfsd will not restart after stopped
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: knfsd
Version: 6.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-05 21:01 UTC by Tim Pepper
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-05 03:24:49 UTC


Attachments (Terms of Use)

Description Tim Pepper 1999-12-05 21:01:43 UTC
If I stop knfsd via "/etc/rc.d/init.d/nfs stop", it will not restart when I
issue the start command.  I get the following output from the startup
script:

[root@jose /root]# /etc/rc.d/init.d/nfs start
Starting NFS services:                                     [  OK  ]
Starting NFS quotas:
Cannot register service: RPC: Timed out
                                                           [FAILED]
Starting NFS mountd:
Cannot register service: RPC: Timed out
mountd: unable to register (mountd, 1, udp).
                                                           [FAILED]
Starting NFS daemon:
nfssvc: Address already in use
                                                           [FAILED]


It hangs for two minutes trying to start the quotas, finally fails, and
then again hangs trying to start mountd, again finally failing.

As this happens in my logs I see:

Dec  5 12:59:03 jose nfs: Starting NFS services:  succeeded
Dec  5 13:02:03 jose rquota[15674]: unable to register (RQUOTAPROG,
RQUOTAVERS, udp).
Dec  5 13:02:03 jose rpc.rquotad: Cannot register service: RPC: Timed out
Dec  5 13:02:03 jose nfs: rpc.rquotad startup failed
Dec  5 13:04:04 jose mountd[15689]: unable to register (mountd, 1, udp).
Dec  5 13:04:04 jose rpc.mountd: Cannot register service: RPC: Timed out
Dec  5 13:04:04 jose rpc.mountd: mountd: unable to register (mountd, 1,
udp).
Dec  5 13:04:04 jose nfs: rpc.mountd startup failed
Dec  5 13:04:04 jose rpc.nfsd: nfssvc: Address already in use
Dec  5 13:04:04 jose nfs: rpc.nfsd startup failed


This happens for both 1.4.4-7 and 1.2.2-4 knfsd versions.  It seems that
the system is otherwise in order.  For both versions of knfsd the services
start fine at boot time, failing only when I've manually stopped the
service and attempted to restart.  The machines in question are 5.1,
upgraded to 6.0.  A friend of mine reports the same things with his 6.1
installations.

The kernel support has been built as modules, which do unload if I stop the
service after booting.  But I reload them by hand.  Loaded modules at the
time of attempting to restart the knfsd service are:

[root@jose /root]# lsmod
Module                  Size  Used by
nfsd                  150040   0
lockd                  30760   0  [nfsd]
sunrpc                 51876   0  [nfsd lockd]
ip_masq_raudio          2736   0
ip_masq_user            2376   0  (unused)

Obviously bouncing the machine is a pretty annoying way to restart the
service.

Comment 1 Riley H Williams 1999-12-05 23:12:59 UTC
I'm not sure what the problem is, but I run three different machines, now all
running under RH 6.1. One is a straight 6.1 install, one is updated from 5.2
direct and the third is updated from 5.1 via 6.0. On all three, I regularly stop
and start nfs using the commands stated, and have never had any problems.

Perhaps we can compare configurations?

Comment 2 Tim Pepper 1999-12-08 06:31:59 UTC
I stand corrected...the problem seems to only appear on 6.0 machines.

Comment 3 jgotts 1999-12-19 07:42:59 UTC
This can happen when /var/lib/nfs/* gets stale information.  If you ever mount
a filesystem from a host that disappears (changes names), KNFS may not start
anymore because it for some reason tries to contact or resolve that old
hostname.  This does not seem to be fixed in the lastest KNFSD beta releases.
(I last checked a couple of months ago).

Comment 4 Cristian Gafton 2000-02-05 03:24:59 UTC
This is a DNS misconfiguration or problems with portmap/tcp_wrappers.

The versions in rawhide do not exhibit this type of problem.


Note You need to log in before you can comment on or make changes to this bug.