Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76087 - File permissions not preserved when importing file system
Summary: File permissions not preserved when importing file system
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Developer Suite
Classification: Retired
Component: eclipse
Version: 1.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Andrew Haley
QA Contact: eclipse-bugs
URL:
Whiteboard:
: 76725 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-16 18:25 UTC by Keith Seitz
Modified: 2006-09-27 18:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-27 18:04:41 UTC


Attachments (Terms of Use)

Description Keith Seitz 2002-10-16 18:25:24 UTC
Description of Problem:
Eclipse doesn't preserve the file permissions on a checked out project; well, it
cannot do it, either, when just importing from an exiting file system!

Steps to Reproduce:
1. Create new C/C++ project (File->New->Project->C Project->blah blah blah)
2. File->import->file system
3. select some version of a sources.redhat.com project

Actual Results:
None of the configure scripts are executable

Expected Results:
File permissions should be preserved. I can't even imagine why they would
magically change when copying a file. Oh, wait, let me guess, don't trust the
OS! Write our own file system utilites.

Additional Information:

Comment 1 Need Real Name 2002-10-28 19:32:39 UTC
*** Bug 76725 has been marked as a duplicate of this bug. ***

Comment 2 Tom Tromey 2002-12-04 22:24:37 UTC
I've checked in the fix.

Comment 3 Jeremy Handcock 2003-08-20 15:22:58 UTC
Reopening: I'm not sure exactly when this reappeared, but I'm seeing this
behavior again in the beehive -15 RPM.

Related to: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=100745

Comment 4 Andrew Haley 2003-08-22 13:40:31 UTC
I can confirm this problem still happens.

I'm looking at it.


Comment 5 Andrew Haley 2003-08-28 15:40:58 UTC
Fix checked in.

Comment 7 Tom Tromey 2006-09-27 18:04:41 UTC
This was fixed a long time ago.



Note You need to log in before you can comment on or make changes to this bug.