Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7594 - Mouse does not work
Summary: Mouse does not work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-05 05:26 UTC by bernardo
Modified: 2015-01-07 23:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-12-06 12:38:12 UTC


Attachments (Terms of Use)

Description bernardo 1999-12-05 05:26:12 UTC
I have a Pentium Pro 200 equipped with an ATI Rage Pro Turbo PCI video card
and a Microsoft Intellimouse.

The problem seems to be, I believe, related to the video driver that is
selected by default (found by installer) or the mouse driver or both.

I was, at first, using Caldera Open Linux 2.3 and I found that, about 50%
of the time, my pointer would show up on my screen when the KDE login
screen showed up, but was frozen.  I was not able to move it.  The other
50% of the time it would work just fine.

I purchased my copy of RedHat Linux 6.1 today only to find the same
problem, only worse.  Now, when I start GNOME, my pointer shows up, but
when I move it, my mouse dissappears and flashes ocassionally throughout
the screen, but I am unable to use it for anything.  Furthermore, when I
reboot MS Windows 98 (if I don't shut the machine down entirely before) my
mouse is not recognized.

I don't know if this is a common problem, if it is a problem related to the
mouse or the video driver.

What I do know, is that it is a problem that is consistent with both RedHat
and Caldera.

Please help.

Bernardo J. Passariello

Comment 1 Jay Turner 1999-12-06 12:38:59 UTC
What type of Intellimouse is this that you are using?  Serial or PS/2?

It sounds like the wrong mouse protocol is getting loaded and used for your
mouse and that is what results in the behavior that you are seeing.

As a workaround, you might want to run "mouseconfig" as root from a command
prompt.  This will ask you to identify your mouse, what port it is on and then
make the appropriate changes for both console and X modes.  Try running X again
and see if the problem is solved.  If you are still seeing problems, then you
will want to run "Xconfigurator" again as root from the command line.  This will
ask questions about the video card that you are using, as well as allow you to
tell which mouse protocol to use under X.  Please reopen this bug is these
solutions do not remedy your problems.


Note You need to log in before you can comment on or make changes to this bug.