Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 75834 - Preferences->Password Change (cosmetic) error message
Summary: Preferences->Password Change (cosmetic) error message
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: usermode
Version: 8.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard:
: 72719 79737 80925 90456 92184 102865 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-13 15:14 UTC by Mark Cooke
Modified: 2013-07-02 22:57 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-13 01:58:12 UTC


Attachments (Terms of Use)

Description Mark Cooke 2002-10-13 15:14:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Cancelling the gui password change box produces an 'Unknown Error' message popup.

A cosmetic annoyance.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open RedHat->Preferences->Password 
2.Click cancel / close window button

Actual Results:  Password dialog appears, vanishes, then an error dialog pops up
after cancelling.

Expected Results:  Error dialog should not be presented to the user.

Additional info:

Comment 1 David Balažic 2002-11-22 00:37:40 UTC
I noticed something similar.
"Preferences"->"Password" , don't enter anything, click "Cancel" :
The dialog disappears and reappears. Click "Cancel" again, the same thing 
happens. Click for the third time , then it finally goes away.
Not error dialog is displayed. I think I did this as root, not sure though.

Comment 2 Marius Andreiana 2003-01-24 11:08:42 UTC
bug 75834 says pressing OK without a password gives the same error message.

I couldn't replicate the behaviour described in comment #1.

Comment 3 Toni Willberg 2003-01-24 11:27:05 UTC
See also #79737 (duplicate of this)


Comment 4 Daniel Resare 2003-01-24 11:56:00 UTC
*** Bug 80925 has been marked as a duplicate of this bug. ***

Comment 5 Matthew Miller 2003-04-16 15:57:45 UTC
This is present in Red Hat Linux 9, starting in usermode 1.67. It didn't happen
in the 1.65 version from phoebe beta 3. I don't think there was a publically
available 1.66 version, and have no idea if it worked there or not. :)
Should the Version for this bug be updated?

More precisely, with usermode 1.65, you get a "The password you typed is
invalid. Please try again", which is also not really correct for having clicked
cancel.

If you press OK without entering a password, it tries to authenticate using a
blank password. This is probably actually correct.

Also, it's not merely the password change applet -- it's anything usermode is
used for.

Comment 6 Matthew Miller 2003-05-07 02:16:05 UTC
The error-on-cancel problem appears fixed in usermode 1.68 in rawhide.

Comment 7 Toni Willberg 2003-05-28 12:26:38 UTC
*** Bug 79737 has been marked as a duplicate of this bug. ***

Comment 8 Brent Fox 2003-06-03 18:59:20 UTC
*** Bug 92184 has been marked as a duplicate of this bug. ***

Comment 9 Mattias Dahlberg 2003-10-18 09:10:19 UTC
Yes, it seems to be fixed. I can't reproduce in Fedora Core.

Comment 10 Miloslav Trmac 2004-02-07 17:24:45 UTC
*** Bug 72719 has been marked as a duplicate of this bug. ***

Comment 11 Miloslav Trmac 2004-02-07 17:26:26 UTC
*** Bug 90456 has been marked as a duplicate of this bug. ***

Comment 12 Matthew Miller 2004-04-07 03:22:20 UTC
*** Bug 102865 has been marked as a duplicate of this bug. ***

Comment 13 Matthew Miller 2004-10-13 01:58:12 UTC
unless someone objects, i'm closing this -- it works in FC2 no problem.


Note You need to log in before you can comment on or make changes to this bug.