Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7569 - tcpdump options dont work.
Summary: tcpdump options dont work.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcpdump
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-03 21:06 UTC by musman
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-12-22 14:49:57 UTC


Attachments (Terms of Use)

Description musman 1999-12-03 21:06:24 UTC
I have identified a problem trying to use tcpdump.

The following command works just fine under redhat 5.x, Solaris, IRIX,
etc. but fails under several different installations of redhat 6.0. I
haven't yet had a chance to replicate it under redhat 6.1.

>tcpdump '(icmp[0] == 8 ) or (port sunrpc)'
tcpdump: unknown port 'sunrpc'

I compiled the same version of tcpdump source under both releases of
redhat, and the redhat 5.x version even runs under 6.0, but I get the
same error as above.

Comment 1 Jeff Johnson 1999-12-03 21:27:59 UTC
There appears to be a getservbyname call that has been taken out, probably
to speed up tcpdump performance.

Meanwhile try putting the port number in numerically (use "111" instead of
"sunrpc"). I suspect that will work ...

Comment 2 Jeff Johnson 1999-12-22 14:49:59 UTC
Your command works in tcpdump-3.4-17 from Raw Hide. If it still doesn't
work for you, check your /etc/nsswithc.conf setup.


Note You need to log in before you can comment on or make changes to this bug.