Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 75663 - [PATCH] /etc/bashrc leaves 'i=/etc/profile.d/$something' in the environment
Summary: [PATCH] /etc/bashrc leaves 'i=/etc/profile.d/$something' in the environment
Keywords:
Status: CLOSED DUPLICATE of bug 117350
Alias: None
Product: Fedora
Classification: Fedora
Component: setup
Version: rawhide
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: EasyFix-Tracker FC2Target
TreeView+ depends on / blocked
 
Reported: 2002-10-10 20:16 UTC by Miloslav Trmac
Modified: 2014-03-17 02:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:49:52 UTC


Attachments (Terms of Use)
Patch to add 'unset i' (deleted)
2003-10-05 15:56 UTC, Miloslav Trmac
no flags Details | Diff

Description Miloslav Trmac 2002-10-10 20:16:45 UTC
I don't really care, but /etc/profile unsets it, so /etc/bashrc might
as well:
echo 'unset i' >> /etc/bashrc

Version-Release number of selected component (if applicable):
setup-2.5.20-1

Comment 1 Miloslav Trmac 2003-07-30 02:51:27 UTC
Same in severn (initscripts-7.28-1)

Comment 2 Miloslav Trmac 2003-10-05 15:56:14 UTC
Created attachment 94937 [details]
Patch to add 'unset i'

Same in FC 0.94 (initscripts 7.34-1).
Attaching a regular patch, the '>> /etc/bashrc' is not the best way anymore.

Comment 3 Miloslav Trmac 2004-04-08 12:42:30 UTC
Same in initscripts-7.48-1.

Comment 4 Bill Nottingham 2004-05-04 04:56:06 UTC

*** This bug has been marked as a duplicate of 117350 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:49:52 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.