Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 75604 - Routes in static-routes file not loading into routing table
Summary: Routes in static-routes file not loading into routing table
Keywords:
Status: CLOSED DUPLICATE of bug 74320
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-10 05:09 UTC by Need Real Name
Modified: 2014-03-17 02:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-01 22:18:24 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-10-10 05:09:14 UTC
Description of Problem:
The /etc/sysconfig/static-routes file is not read properly when the
/etc/init.d/network script is launched and thus the static route entries are not
updated in the network routing table.

Version-Release number of selected component (if applicable):


How Reproducible:
The static-routes file is not read irregardless of tab or space separation
within the file.

Steps to Reproduce:
1. add entries into /etc/sysconfig/static-routes file
2. service network stop. Service network start
3. netstat -rn.

Actual Results:
No entries from static-routes file seen in routing table.

Expected Results:


Additional Information:
A temporary fix to the problem was to copy an older
/etc/sysconfig/network-scripts/ifup-routes file from a RedHat 7.1 server onto
the 8.0 server. Ran service network restart and finally got the routing tables
to show up properly.

Comment 1 Need Real Name 2002-11-01 22:18:11 UTC
In addition, the /etc/sysconfig/network-scripts/ifup-routes script from RH7.3
functions correctly as well in RH8.0.

Comment 2 Bill Nottingham 2002-11-12 06:40:31 UTC

*** This bug has been marked as a duplicate of 74320 ***


Note You need to log in before you can comment on or make changes to this bug.