Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7556 - all X11 output frozen while moving/resizing windows
Summary: all X11 output frozen while moving/resizing windows
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: enlightenment
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-03 16:42 UTC by David Balažic
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-17 20:57:32 UTC


Attachments (Terms of Use)

Description David Balažic 1999-12-03 16:42:07 UTC
While moving or rezising windows ( not opaque mode , but only with frame
outline ) all gfx output is frozen, like on AmigaOS :-)
I think this even causes xmms to stop playing , because it tries to update
the time-position. Happens with other windowmanagers too.
( But not on IRIX 5.3 , so I don't see why it must block on linux )

Comment 1 Elliot Lee 2000-01-17 20:57:59 UTC
Cannot reproduce. It is possible that on a very slow system, moving the window
around would use up all the CPU time.

Comment 2 David Balažic 2000-01-18 14:06:59 UTC
The enlightenment window manager ( and some others too , like the CDE WM )
blocks all gfx while the outline of the window is visible, while moving or
resizing it. Note that the moving-mode is outline/boxed/... so that only the
a single box is dragged and the window appears at the new position when the
mouse button is released ( as opposed to opaque moving , when the window is
moved/resized in real-time as the mouse is moved ). Whether this is a bug or
just a compromise between speed and functionality is a matter of opinion.
The 4Dwm ( from IRIX ) does not block gfx , tested with the same X server, but
the outline flickers, they must have some special support in the SGI X server.


Note You need to log in before you can comment on or make changes to this bug.