Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 75486 - iproute does not contain htb support whereas kernel does
Summary: iproute does not contain htb support whereas kernel does
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: iproute
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Brock Organ
URL:
Whiteboard:
: 82008 119606 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-08 23:49 UTC by Tom Eastep
Modified: 2015-03-05 01:11 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-16 11:14:43 UTC


Attachments (Terms of Use)

Description Tom Eastep 2002-10-08 23:49:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
The kernel (2.4.18-14) shipped with RH8.0 includes Hierarchical Token Bucket
(HTB) support. The 'tc' program in iproute-2.4.7-5 does not appear to include
HTB support.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. tc qdisc add dev eth0 root handle 1: htb default 30
2. tc qdisc show
3.
	

Actual Results:  [root@wookie root]# tc qdisc add dev eth0 root handle 1: htb
default 30
Unknown qdisc "htb", hence option "default" is unparsable
[root@wookie root]# tc qdisc show
[root@wookie root]#


Expected Results:  [root@wookie root]# tc qdisc add dev eth0 root handle 1: htb
default 30
[root@wookie root]# tc qdisc show
qdisc htb 1: dev eth0 r2q 10 default 30 direct_packets_stat 0
[root@wookie root]#

Additional info:

Replacing /sbin/tc with the tc binary from the HTB site
(http://luxik.cdi.cz/~devik/qos/htb/) results in correct results.

Comment 1 Phil Knirsch 2003-01-16 10:53:18 UTC
*** Bug 82008 has been marked as a duplicate of this bug. ***

Comment 2 Phil Knirsch 2003-01-16 11:14:43 UTC
Will be included in iproute-2.4.7-7, available shortly via rawhide.

Read ya, Phil

Comment 3 Nosuko 2004-03-31 22:19:28 UTC
*** Bug 119606 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.