Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 75465 - ancient xdvi in RH8?
Summary: ancient xdvi in RH8?
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tetex
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-08 20:30 UTC by Martijn Feleus
Modified: 2007-04-18 16:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-23 15:29:21 UTC


Attachments (Terms of Use)

Description Martijn Feleus 2002-10-08 20:30:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
The version reported by xdvi is 22.05d-k, that of pxdvi 22.15-k. Is that mere
cosmetics or is this indeed the xdvi of *3 years* ago?
Current xdvi version is 22.63, adding all sorts of nice functionality (sort of
like textures on mac, which everyone always raves about).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
just run (p)xdvi -version
	

Additional info:

Comment 1 Tim Waugh 2002-10-08 20:33:19 UTC
Does 22.63 support Japanese?

Comment 2 Martijn Feleus 2002-10-09 13:55:09 UTC
I have no idea; neither the site nor the source seems to mention Japanese though.
(http://math.berkeley.edu/~vojta/xdvi.html)

Comment 3 Tim Waugh 2002-10-09 14:00:36 UTC
We can't lose Japanese support in pxdvi, and I'd rather keep xdvi at the same 
revision.

Comment 4 Martijn Feleus 2002-10-09 14:25:50 UTC
I imagine that the newer version would since the older version does, right? Or
do you patch the stock xdvi source? I have no idea how to verify this, however,
since I'm no programmer, merely a sysadmin.

I think that it would be worthwhile to try upgrading xdvi though, since the new
features are very nice from what I read.

Comment 5 Tim Waugh 2002-10-09 14:41:59 UTC
Stock 22.15 doesn't support Japanese.

Comment 6 Gerald Teschl 2002-10-21 19:55:05 UTC
I also feel that the version of xdvi should be updated. Several users
have complained to me about this.

Moroever, I do not understand the issue about japanese support? Xdvi displays
whatever tex produces. So it will support whatever tex supports.

Comment 7 Tim Waugh 2002-10-21 20:40:12 UTC
Look at the differences between pxdvi and xdvi.  I don't understand all the
issues myself.

Comment 8 Gerald Teschl 2002-10-23 10:21:35 UTC
The only difference between pxdvi and xdvi seems to be navigation.
pxdvi has an extended sidebar where a page can be selected and they use
slightley different keyboard shortcuts.

Comment 9 Tim Waugh 2002-10-23 10:30:33 UTC
Then look at the patch.  It is quite extensive I think.

Comment 10 Tim Waugh 2003-05-23 15:29:21 UTC
Rawhide version has a newer xdvi now.


Note You need to log in before you can comment on or make changes to this bug.