Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 75415 - ICE on binutils/gas/config/tc-ppc.c
Summary: ICE on binutils/gas/config/tc-ppc.c
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc
Version: 1.0
Hardware: athlon
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
: 80470 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-08 08:27 UTC by namsh
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-16 23:41:02 UTC


Attachments (Terms of Use)
tc-ppc.i (deleted)
2002-10-16 23:33 UTC, namsh
no flags Details

Description namsh 2002-10-08 08:27:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021004

Description of problem:
gcc -DHAVE_CONFIG_H -I. -I. -I. -D_GNU_SOURCE -I. -I. -I../bfd -I./config
-I./../include -I./.. -I./../bfd -I./../intl -I../intl
-DLOCALEDIR="\"/usr/GNUPPC/share/locale\""   -W -Wall -Wstrict-prototypes
-Wmissing-prototypes -O2 -static -c ./config/tc-ppc.c
config/tc-ppc.c: In function `md_assemble':
config/tc-ppc.c:2188: warning: right shift count >= width of type
config/tc-ppc.c:2190: warning: right shift count >= width of type
config/tc-ppc.c:2195: warning: right shift count >= width of type
config/tc-ppc.c:2197: warning: right shift count >= width of type
config/tc-ppc.c:2202: warning: right shift count >= width of type
config/tc-ppc.c:2204: warning: right shift count >= width of type
config/tc-ppc.c:2209: warning: right shift count >= width of type
config/tc-ppc.c:2211: warning: right shift count >= width of type
config/tc-ppc.c: In function `md_apply_fix3':
config/tc-ppc.c:5404: warning: right shift count >= width of type
config/tc-ppc.c:5411: warning: right shift count >= width of type
config/tc-ppc.c:5418: warning: right shift count >= width of type
config/tc-ppc.c:5425: warning: right shift count >= width of type
config/tc-ppc.c:5553: Internal compiler error in simplify_subreg, at
simplify-rtx.c:2452

If I removed '-O2', no ICE.

I used gcc-3.2-7.src.rpm
And the as/config/tc-ppc.c is 1.51.2.2 (binutils-2_13-branch).

Version-Release number of selected component (if applicable):
gcc-3.2-7

How reproducible:
Always

Steps to Reproduce:
1. Run the compile command it 'Description'.
2.
3.
	

Actual Results:  config/tc-ppc.c:5553: Internal compiler error in
simplify_subreg, at simplify-rtx.c:2452

Expected Results:  No ICE.

Additional info:

Comment 1 Jakub Jelinek 2002-10-16 14:03:17 UTC
Please attach tc-ppc.i.

Comment 2 namsh 2002-10-16 23:33:52 UTC
Created attachment 80745 [details]
tc-ppc.i

Comment 3 namsh 2002-10-16 23:40:49 UTC
The tc-ppc.i is build with cvs gcc (gcc-3_2-branch, 20021015).
And the result was same (And I don't file it to GCC gnatsweb).

config/tc-ppc.c:5553: Internal compiler error in simplify_subreg, at
simplify-rtx.c:2452



Comment 4 Jakub Jelinek 2002-11-27 17:19:27 UTC
Should be fixed in gcc-3.2.1-1 in rawhide.

Comment 5 Jakub Jelinek 2002-12-27 12:00:01 UTC
*** Bug 80470 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.