Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 75241 - RFE: only root can switch profiles
Summary: RFE: only root can switch profiles
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-network
Version: rawhide
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
: 102664 117829 (view as bug list)
Depends On:
Blocks: 74873 81720
TreeView+ depends on / blocked
 
Reported: 2002-10-05 21:14 UTC by Satish Balay
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-13 10:56:29 UTC


Attachments (Terms of Use)

Description Satish Balay 2002-10-05 21:14:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
A non-root user should be able to switch network profiles (in the same way he
can activate/deactiveate a network connection)

The tools that should provide this feature are: 
/usr/bin/neat-control
/usr/bin/redhat-config-network 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Using redhat-config-netowrk configure eth0 (say wireless pcmcia card), create
2 profiles. create a copy of eth0 configuration with different wireless
settings, and then enable eth0-Home for Home profile and ethh0-Work for Work
profile.

2.enable 'Allow Users to enable/diable this device' in the device properties for
both'.

3. Now select Home profile as default

The above 3 are done as root

4. Now as a regular user start up /usr/bin/neat-control

5. Now try activating eth0-Home. This works

6. Using the same tool - try activating eth0-Work. This doesn't work

Actual Results:  6 - form above doesn't work (because 'root' had selected 'Home'
profile as active)

Expected Results:  should have a way for non-root user to switch profiles.

Additional info:


Perhaps redhat-config-network can have the following function

- A checkbox - next to profiles - which indicates "Enable user to switch profiles'

When this checkbox is enabled - neat-control shows an option to switch profiles
(when invoked by non-root user)

Comment 3 Harald Hoyer 2003-12-01 12:55:45 UTC
*** Bug 102664 has been marked as a duplicate of this bug. ***

Comment 4 Phillip Heller 2004-03-09 01:50:10 UTC
*** Bug 117829 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.