Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 75217 - The on screen font metrics are broken in abiword
Summary: The on screen font metrics are broken in abiword
Keywords:
Status: CLOSED DUPLICATE of bug 72633
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: abiword
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL: http://rawlingsorg.hypermart.net/Scre...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-05 16:11 UTC by Kenneth Rawlings
Modified: 2007-04-18 16:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-09 23:30:14 UTC


Attachments (Terms of Use)

Description Kenneth Rawlings 2002-10-05 16:11:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i586; U;) Gecko/20020809

Description of problem:
When typing a document into abiword the font metrics are incorrect.  The text is
spaced too far apart causing text to display beyond the edge of the page.  The
text will eventually wrap as it is supposed to, but the visual representation is
incorrect.  I have printed out the resulting page and the text is printed out
correctly on the page.  This seems to only be an on screen problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open abiword
2. Start typing a sentence and keep typing until it wraps.
3.
	

Actual Results:  Some of the text is not visible because it has gone beyond the
edge of the displayable surface of the application.

Expected Results:  The full text should be displayed and formatted correctly on
screen.

Additional info:

Comment 1 Michael Redd 2002-10-06 21:14:06 UTC
I've had the same problem with AbiWord in RH8. The only workaround that I found
for this was chosing not to upgrade your XFree86 packages during setup. Of
course, this only works if you're upgrading to RH8 from a previous version of
Red Hat Linux.

Comment 2 Kenneth Rawlings 2002-10-07 00:09:25 UTC
That's interesting that you found that it was related to XFree86, but it makes
sense.  I was wondering if it had something to do with gtk because I have since
found that gnumeric has the same issues.

Comment 3 Kenneth Rawlings 2002-10-09 23:30:08 UTC
I am finding that the cause of this bug is the same cause as another abiword bug
I reported.

Refer to the following resources:

1. Bug #75298
2. http://bugzilla.abisource.com/show_bug.cgi?id=1543

If you call up abiword using 'LANG=en_US abiword' it fixes the problem.  A
better long-term solution needs to be found though.

Comment 4 Kenneth Rawlings 2002-10-11 18:21:58 UTC
sorry, I found this was a duplicate.

*** This bug has been marked as a duplicate of 72633 ***


Note You need to log in before you can comment on or make changes to this bug.