Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 75193 - problems searching for non alphabetic characters in unicode locale
Summary: problems searching for non alphabetic characters in unicode locale
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: man
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-05 09:50 UTC by Michael Wardle
Modified: 2007-04-18 16:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-22 21:44:46 UTC


Attachments (Terms of Use)

Description Michael Wardle 2002-10-05 09:50:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When viewing a manual page using less as the pager, I like to search
for command parameters by typing: slash-hyphen-flag (such as /-N).
In Red Hat 7, this worked, but after a clean install of Red Hat 8, it
does not.

There are also problems searching for other non-alphabetic characters
such as single quotes.


Version-Release number of selected component (if applicable):
358-28

How reproducible:
Always

Steps to Reproduce:
1. man wget
2. /-N
	

Actual Results:  less displays the error message "Pattern not found"

Expected Results:  cursor is moved to the next instance of "-N"

Additional info:

I notice that Red Hat 8 now uses the Unicode character set in many
places by default.  I tried changing $LANG from en_AU.UTF-8 (this
was selected when I chose English-Australia as the default language
during installation) to en_AU, and I was again able to search for
special characters such as the hyphen.

The same problem appears to exist in the equivalent en_US locales.

Comment 1 Karsten Hopp 2002-11-04 11:15:02 UTC
not a bug in less, but in man/nroff (try man -P more manpage to see that the 
same occurs with more)

Comment 2 Florian La Roche 2002-11-26 13:44:23 UTC
groff-1.18.1-1 or newer should have a patch that changes the hyphen
character, so that you can search it in "less" again.

greetings,

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.