Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7518 - PCMCIA CDROM - fopen(stabfile) failed
Summary: PCMCIA CDROM - fopen(stabfile) failed
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
: 7845 10396 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-02 19:40 UTC by Tom Gagne
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-04-24 12:49:16 UTC


Attachments (Terms of Use)

Description Tom Gagne 1999-12-02 19:40:19 UTC
Everything boots fine, the search for PCMCIA cards beeps twice, my cdrom
spins-up and everything is looking fine until it asks me what device to
load RHAT from, and it only give me the option to boot from hard disk
(/dev/hda1).

From the alt-f4 screen:

<30>.. cardmgr[14] socket 1: EXP CD940 CD-ROM
<30>.. cardmgr[14] executing: 'modprobe ide_cs.o'
<4>hdc: OTI-911[10-3] ACE[0A.0A-08:20] DC24M 4S, ATAPI CDROM drive
<4>ide1 at 0x170-0x177,0x376 on irq 3
<4>jdc: ATAPI 2X CD-ROM DRIVE, 120kB Cache
<6>Uniform CDROM driver Revision: 2.56
<6>ide_cs: jdc: Vcc = 5.0, Vpp = 0.0
<30>.. cardmgr[14]: fopen(stabfile failed: No such file or directory
<30>.. cardmgr[14] exiting

Comment 1 Tom Gagne 1999-12-02 20:58:59 UTC
Just to make sure it wasn't a device problem, I tried loading Slackware 2.0.35
and it was able to detect and use the CDROM drive without problem.

CD = EXP CD Traveler 2020
20X max Portable CD-ROM Player

I'm doing this on an IBM Thinkpad 755C

Comment 2 Jay Turner 1999-12-03 14:46:59 UTC
This issue has been assigned to a developer for further action.

Comment 3 RL "Bob" Morgan 2000-01-05 00:25:59 UTC
I had the same experience with my IBM ThinkPad 560Z and an IBM Max Portable
CD-ROM (IBM CD-20X Series ATAPI via IBM IDE PC card, Uniform CDROM driver
Revision 2.55).  I am attempting to upgrade from RH 5.2 to 6.1.  When booted
normally I'm able to mount the CD-ROM drive just fine and read files from the RH
6.1 CD.

Comment 4 koni 2000-01-16 01:49:59 UTC
I also have had this experience, with some new information to add:

(1) The problem seems to have nothing to do with the lack of existance of
/var/run/stab, as I tried the directory /var/run in initrd.img on the pcmcia
install disk, and this did not solve the problem

(2) I CAN use my network PCMCIA card without any problems and do and NFS
install, but neither of my SCSI PCMCIA cards work. I get the double beep, and
the information is correctly displaced on the ALT-F4, but no SCSI devices listed
when I try to choose a partition to install from

this leading me to conclude that cardmgr can exit all it wants (does so with my
network card -- but the network still works) after its loaded the drivers. Why
the SCSI stuff doesn't work? Sounds like perhaps a problem with the installer
noticing it has SCSI drivers loaded and thus SCSI partitions hanging out.

Comment 5 koni 2000-01-16 23:34:59 UTC
Hey, any of you know where I can find the source code to the installer program?
I see that all those executables are stuffed together into that one program in
/sbin but can't play around with any more ideas about how to fix this problem
without the source code for that file.

Comment 6 Jay Turner 2000-02-22 19:06:59 UTC
*** Bug 7845 has been marked as a duplicate of this bug. ***

Comment 7 Jay Turner 2000-04-24 12:49:59 UTC
*** Bug 10396 has been marked as a duplicate of this bug. ***

Comment 8 Erik Troan 2000-08-04 18:15:08 UTC
The core of this problem is that pcmcia cdrom's don't show up in /proc/ide,
which we need to know what exists on the bus. Apparently, the /proc/ide code
cannot handle removeable devices, and this is hard to fix :-(


Note You need to log in before you can comment on or make changes to this bug.