Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7514 - Headless Install Doesn't Work in 6.1
Summary: Headless Install Doesn't Work in 6.1
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-02 17:43 UTC by Mark J. Watson
Modified: 2015-01-07 23:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-09 14:37:01 UTC


Attachments (Terms of Use)

Description Mark J. Watson 1999-12-02 17:43:17 UTC
I tried to perform a headless install on an Intel based computer by
connecting a DEC VT510 serial terminal to COM1 (null modem cable, and
H8571-J [mmj to DB9] connector) and typing 'linux serial' from a temporaily
installed keyboard on the PC. I ended up having to install a video card,
monitor, keyboard and mouse on the computer to get 6.1 installed. Having
the video card an monitor installed I agian typed in 'linux serial' and it
proceeded with the normal install without transfering control to the serial
terminal. Once the installation was complete I opened up a getty on COM1
and the serial terminal worked fine.

inittab entry
S0:2345:respawn:/sbin/getty ttyS0 DT9600 vt100

reread inittab file without rebooting
telinit q

If you try the same proceedure in 6.0 it works. You shouldn't have to
install a video card, monitor, keyboard and mouse to install linux if it is
going to be used as a file server/firewall/router. Most of those computers
are remotely administered and those devices can present a security risk
especially if the computer is located in a non secure area.

Comment 1 Jay Turner 1999-12-02 18:14:59 UTC
We are aware of bugs with the serial installs on intel workstations.  It will
definitely be back to its 6.0-behavior in the next release.

Comment 2 Mark J. Watson 1999-12-03 14:05:59 UTC
There needs to be some sort of prompt at the serial terminal during the install
process so you don't have to connect a keyboard to the PC during the install.
The SPARC install is a good example.

Comment 3 Jay Turner 2000-02-09 14:36:59 UTC
With the latest installer, you can type "linux console=ttyS0" at the syslinux
prompt and start a serial installation (of course, ttyS1, S2, etc. work as well)


Note You need to log in before you can comment on or make changes to this bug.