Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 75138 - Panel Crashes after moving to vertical postion on Right side of screen.
Summary: Panel Crashes after moving to vertical postion on Right side of screen.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-panel
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
: 73398 73808 75578 77368 77661 78014 78857 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-04 19:02 UTC by Nate Golnik
Modified: 2008-05-01 15:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-04 19:03:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:219 normal SHIPPED_LIVE A common GNOME panel crash has been resolved 2003-07-02 04:00:00 UTC

Description Nate Golnik 2002-10-04 19:02:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523

Description of problem:
Fresh install of an 8.0 box.  Dragged the panel to the right so it was vertical.
 Logged out and loged back in.  The Panel dies, puts up a crash report, click
ok, panel respawns, puts up a crash report....
remove .gconf and start over.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Take a Fresh install, log in as a user
2.move panel to right side of screen
3.log out
4.log back in.
	

Actual Results:  Panel crashes spits a warning, respawns and crashes again.

Expected Results:  no crash

Additional info:

Comment 1 Havoc Pennington 2002-10-04 19:14:43 UTC
Tracked as http://bugzilla.gnome.org/show_bug.cgi?id=94625

(the workaround for now is no tray applets on vertical panels)

Comment 2 Havoc Pennington 2002-10-09 23:34:38 UTC
*** Bug 75578 has been marked as a duplicate of this bug. ***

Comment 3 Havoc Pennington 2002-10-09 23:35:28 UTC
I'm working on a new panel package btw, for this and menu editing.

Comment 4 Michael A. Peters 2002-10-17 21:12:51 UTC
I hate to nit pick- but there really should be an errata about this at least
describing the problem, how to avoid it, what to do if it gets you, and when a
fix will be released.

Judging from http://bugzilla.gnome.org/show_bug.cgi?id=94625 this is a fairly
commonly encountered bug.

I ran into it my first day using RH 8 - and others have too.
It's serious enough there should be an errata on it.

Comment 5 Havoc Pennington 2002-10-18 04:07:32 UTC
Yes, agreed. I want to get menu editing in the errata too, that's the hard 
part.

Comment 6 Havoc Pennington 2002-10-21 16:42:54 UTC
Someone suggested mentioning how to recover from this:
go to a virtual console (Ctrl+Alt+F1) or ssh in to the machine,
move ~/.gconf/apps/panel to ~/.old-panel-config or something, 
and then reconfigure the panel (not putting the tray applet on 
the vertical panel)

Comment 7 Havoc Pennington 2002-11-05 21:53:23 UTC
*** Bug 77368 has been marked as a duplicate of this bug. ***

Comment 8 Havoc Pennington 2002-11-12 03:22:10 UTC
*** Bug 77661 has been marked as a duplicate of this bug. ***

Comment 9 Chip Turner 2002-11-18 17:33:09 UTC
*** Bug 78014 has been marked as a duplicate of this bug. ***

Comment 10 Havoc Pennington 2002-12-06 00:29:11 UTC
*** Bug 78857 has been marked as a duplicate of this bug. ***

Comment 11 Havoc Pennington 2003-01-08 03:22:45 UTC
*** Bug 73398 has been marked as a duplicate of this bug. ***

Comment 12 Havoc Pennington 2003-01-08 03:58:58 UTC
*** Bug 73808 has been marked as a duplicate of this bug. ***

Comment 13 Havoc Pennington 2003-07-02 22:51:25 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-219.html



Note You need to log in before you can comment on or make changes to this bug.