Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 75077 - HD install fails when images on partition not root on existing installation
Summary: HD install fails when images on partition not root on existing installation
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
: 75407 75410 75500 76179 76221 80130 84813 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-04 04:29 UTC by Bob Hockney
Modified: 2007-04-18 16:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-25 14:59:06 UTC


Attachments (Terms of Use)
traceback (deleted)
2002-10-04 04:30 UTC, Bob Hockney
no flags Details
Traceback of the Unhandled Exception when installing from CD or FTP. (deleted)
2003-01-16 05:48 UTC, Need Real Name
no flags Details

Description Bob Hockney 2002-10-04 04:29:19 UTC
Description of problem:
When attempting to upgrade 7.3 -> 8.0 install fails after boot loader question
but before finding packages to upgrade under these conditions:

Floppy boot

Hard disk install (therefore text mode)

ISO images are at the top of partition directory tree, but partition is not root
partition of installation being upgraded.

If the ISO images are not at the top of the tree, or are in / of installation
being upgraded, the problem does not occur.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Attempt upgrade with ISO images at top of non-/ partition tree
2.Select HD install, upgrade, and give image and installation locations
3.Accept other defaults
	

Actual Results:  Crash (traceback attached) after boot loader question but
before looking for packages to upgrade

Expected Results:  continue with package selection

Additional info:

Comment 1 Bob Hockney 2002-10-04 04:30:13 UTC
Created attachment 78524 [details]
traceback

Comment 2 Jeremy Katz 2002-10-07 20:23:57 UTC
Did you have the docs CD in the same directory?

Comment 3 Bob Hockney 2002-10-08 02:09:15 UTC
Yes, I did.  When I moved it the problem went away.  Not sure why this made a 
difference, but it did.

Comment 4 Jeremy Katz 2002-10-09 15:28:57 UTC
*** Bug 75407 has been marked as a duplicate of this bug. ***

Comment 5 Jeremy Katz 2002-10-09 15:30:35 UTC
Okay, workaround for now is to move the documentation CD to a different
directory.  The reason why this happens now is that we've made the disc
identification scheme the same for all of the CDs included in Red Hat Linux and
so the documentation CD looks like it could be a disc 1.



Comment 6 Jeremy Katz 2002-10-09 15:30:40 UTC
*** Bug 75410 has been marked as a duplicate of this bug. ***

Comment 7 Jeremy Katz 2002-10-09 15:38:13 UTC
*** Bug 75500 has been marked as a duplicate of this bug. ***

Comment 8 Jeremy Katz 2002-10-18 15:48:12 UTC
*** Bug 76179 has been marked as a duplicate of this bug. ***

Comment 9 Jeremy Katz 2002-10-18 15:51:39 UTC
*** Bug 76221 has been marked as a duplicate of this bug. ***

Comment 10 Jeremy Katz 2002-10-25 19:29:58 UTC
And I've put a fix for this in CVS now

Comment 11 Michael Fulbright 2002-12-20 17:38:25 UTC
Time tracking values updated

Comment 12 Need Real Name 2003-01-16 05:48:57 UTC
Created attachment 89403 [details]
Traceback of the Unhandled Exception when installing from CD or FTP.

Comment 13 Need Real Name 2003-01-16 05:54:16 UTC
Comment on attachment 89403 [details]
Traceback of the Unhandled Exception when installing from CD or FTP. 

I'm trying to upgrade from 6.2 to 8.0, using CDs or FTP.  Any workarounds other
than the one mentioned earlier??

Comment 14 Sami-Pekka Hallikas 2003-01-26 21:56:04 UTC
I had this same problem, but didn't find any solution for it... So I searched 
it myself (even I don't know anything about python).

Anaconda uses 'oldhd' type installation, when not using .iso images.

There is few typos on anacondas harddrive.py ...
Line 82 is:
        hl = HeaderListFromFile(self.tree + "/RedHat/base/hdlist")
And it SHOULD be:
        hl = HeaderListFromFile(self.tree + self.path + "/RedHat/base/hdlist")

Also same problem in line 88 (file: hdlist2)

... Maybe even somewhere else, but when I fixed that. Updated .pyc file 
in 'runtime image' .. Worked just fine for me.

Now everybody knows how to FIX this, I hope :)


Comment 15 Jeremy Katz 2003-02-19 13:17:35 UTC
*** Bug 80130 has been marked as a duplicate of this bug. ***

Comment 16 Michael Fulbright 2003-02-21 17:09:48 UTC
*** Bug 84813 has been marked as a duplicate of this bug. ***

Comment 17 Brent Fox 2003-05-25 14:59:06 UTC
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.


Note You need to log in before you can comment on or make changes to this bug.