Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 75015 - sound config broken with sound card and audio USB
Summary: sound config broken with sound card and audio USB
Alias: None
Product: Fedora
Classification: Fedora
Component: kudzu
Version: 2
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
: 72285 102241 107905 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2002-10-03 18:38 UTC by Paul Jenner
Modified: 2014-03-17 02:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2004-09-09 20:47:40 UTC

Attachments (Terms of Use)

Description Paul Jenner 2002-10-03 18:38:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
(cf. bug 72285)

I have a soundcard (Creative SB Live! - module emu10k1) and a USB audio device
(Philips camera - pwc module). Under workaround advice from bug 72285 (raised
for Null), I initially installed Red Hat 8.0 without the USB device plugged in.
Firstboot found the SB Live! fine and played the audio test fine.

On reboot, I plugged in the USB device and kudzu picked it up and configured it
(although noting its name as "unknown"). /etc/modules.conf had been configured
with two sound devices - sound-slot-0 pointed at the emu10k1 module and
sound-slot-1 pointed at the "audio" module. Both modules were loaded when I
checked in normal operation.

When I played an ogg file through xmms with the OSS driver, I got no sound and
the playrate shot through far too quickly. When I "rmmod"d the "audio" driver
and tried again, all worked perfectly. However, as exepected, on reboot the same
situation occurred - "audio" loaded, xmms did not play, "rmmod audio" and all
works again.

It appears that when kudzu sets the USB audio device as sound-slot-1, this is
incorrectly picked as preferential destination for sound output.

Version-Release number of selected component (if applicable):

How reproducible:
Didn't try (only installed once :-)
However is reproduced from Null (cf. bug 72285)

Steps to Reproduce:
1. install system with SB Live!
2. attach a USB audio device and reboot, getting kudzu to set it up
3. play audio through xmms and get no sound and speedy playrate
4. rmmod audio
5. play audio through xmms again fine

Additional info:
Apologies for effectively re-bugging bug id 72285 but hopefully this is clearer
and against a full product.

Comment 1 Paul Jenner 2002-10-03 18:39:39 UTC
*** Bug 72285 has been marked as a duplicate of this bug. ***

Comment 2 Paul Jenner 2003-01-04 14:35:27 UTC
Moved to phoebe from 8.0 as this is still happening and I guess its too late to
fix for 8.0 now :-)

Synopsis so this can be seen like a new phoebe bug without cruft:

I have a system with USB camera (pwc) and sound-card (emu10k1). kudzu and
friends detect both and load the emu10k1 module for the sound-card and audio
module for the audio capability of the camera (microphone etc.).

Unfortunately the audio module appears to take preference over the emu10k1
module for sound output and so no sound appears to work (test sound in
redhat-config-soundcard, xmms etc.) rmmod the audio module and all works again.

This is a reasonable bug becuase a) new users would think audio was simply
broken and b) it takes some unhelpful poking around for even experienced users
to solve.

Version-Release number of selected component (if applicable):

How reproducible:
Every time

Comment 3 Paul Jenner 2003-02-20 21:27:24 UTC
For the record, this is confirmed against Phoebe beta 3:

[root@localhost root]# rpm -q kudzu redhat-config-soundcard

Comment 4 Bill Nottingham 2003-08-12 21:32:12 UTC
*** Bug 102241 has been marked as a duplicate of this bug. ***

Comment 5 Bill Nottingham 2003-10-27 02:44:02 UTC
*** Bug 107905 has been marked as a duplicate of this bug. ***

Comment 6 Paul Jenner 2004-09-09 20:43:57 UTC
I am still seeing the issue in Fedora Core 2.

If I boot FC2 with the USB camera plugged in, the USB audio takes
preference and I get no sound out of apps, including
system-config-soundcard. If I boot without the USB camera plugged in,
sounds works fine via the emu10k1 sound card.

Comment 7 Bill Nottingham 2004-09-09 20:47:40 UTC
This should be fixed in the devel tree.

Note You need to log in before you can comment on or make changes to this bug.