Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 75014 - Crystal Audio soundcard not properly detected
Summary: Crystal Audio soundcard not properly detected
Keywords:
Status: CLOSED DUPLICATE of bug 72045
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-soundcard
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-03 18:35 UTC by Aric Blumer
Modified: 2007-04-18 16:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-23 18:47:10 UTC


Attachments (Terms of Use)

Description Aric Blumer 2002-10-03 18:35:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
I have a Crystal Audio sound card. Output from /proc/isapnp: "Card 1
'CSC6835:CS4236B' PnP version 1.0 Product version 0.1" This card is not properly
detected by the gnome sound card detection program nor does the gnome volume
control work.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run the Redhat->System Setting->Soundcard Detection menu item.
2.Run sndconfig to correctly detect the sound card.
3.Then run the Redhat->Sound & Video->Volume Control menu item.
	

Actual Results:  The sound card detection program simply says that there is no
sound card detected.

The volume program fails with an error: "An error occurred while loading or
saving configuration information for gnome-volume-control. Some of your
configuration settings may not work properly." When I click on details, it says
this:
  Bad key or directory name:
 "/apps/gnome-volume-control/OSS-Crystal_audio_controller_(CS423-1/vol": `(' is
an invalid character in key/directory names


Expected Results:  The sound card should have been detected, and the volume
control should work.

Additional info:

The sound card worked just fine in RedHat Linux 7.3, and I got it to work in
RH8.0 using sndconfig (the text version).  aumix-minimal also controls the
volume just fine, so this is a problem in the GUI apps.

Comment 1 Need Real Name 2002-10-13 14:45:25 UTC
I have the excat same problem with an Opti 16 sound card that was detected 
perfectly in v7.3

Comment 2 Guido 2002-10-23 18:47:03 UTC
I have a AW35/Pro sound card with Crystal CS4232 chipset.

I have the same problem described ubove, but the output from /proc/isapnp is 
quite different (see the following text).


Card 1 'CSCd937:AW35/Pro (Resource R2.2-D7)' PnP version 1.0 Product version 0.1
  Logical device 0 'CSC0000:WSS/SB'
    Device is active
    Active port 0x534,0x388,0x220
    Active IRQ 5 [0x2]
    Active DMA 1,3
    Resources 0
      Priority preferred
      Port 0x534-0x534, align 0x3, size 0x4, 16-bit address decoding
      Port 0x388-0x388, align 0x7, size 0x8, 16-bit address decoding
      Port 0x220-0x220, align 0x1f, size 0x10, 16-bit address decoding
      IRQ 5 High-Edge
      DMA 1 8-bit byte-count compatible
      DMA 0,3 8-bit byte-count compatible
      Alternate resources 0:1
        Priority acceptable
        Port 0x534-0xffc, align 0x3, size 0x4, 16-bit address decoding
        Port 0x388-0x388, align 0x7, size 0x8, 16-bit address decoding
        Port 0x220-0x260, align 0x1f, size 0x10, 16-bit address decoding
        IRQ 5,7,2/9,11,12,15 High-Edge
        DMA 1,3 8-bit byte-count compatible
        DMA 0,1,3 8-bit byte-count compatible
      Alternate resources 0:2
        Priority functional
        Port 0x534-0xffc, align 0x3, size 0x4, 16-bit address decoding
        Port 0x388-0x3f8, align 0x7, size 0x8, 16-bit address decoding
        Port 0x220-0x300, align 0x1f, size 0x10, 16-bit address decoding
        IRQ 5,7,2/9,11,12,15 High-Edge
        DMA 0,1,3 8-bit byte-count compatible
  Logical device 1 'CSC0001:GAME'
    Device is active
    Active port 0x200
    Resources 0
      Priority preferred
      Port 0x200-0x200, align 0x7, size 0x8, 16-bit address decoding
      Alternate resources 0:1
        Priority acceptable
        Port 0x208-0x208, align 0x7, size 0x8, 16-bit address decoding
  Logical device 2 'CSC0010:CTRL'
    Device is not active
    Resources 0
      Priority preferred
      Port 0x120-0xff8, align 0x7, size 0x8, 16-bit address decoding
  Logical device 3 'CSC0003:MPU'
    Device is active
    Active port 0x330
    Active IRQ 11 [0x2]
    Resources 0
      Priority preferred
      Port 0x330-0x330, align 0x7, size 0x2, 16-bit address decoding
      IRQ 2/9 High-Edge
      Alternate resources 0:1
        Priority acceptable
        Port 0x330-0x360, align 0x7, size 0x2, 16-bit address decoding
        IRQ 2/9,11,12,15 High-Edge
      Alternate resources 0:2
        Priority functional
        Port 0x330-0x3e0, align 0x7, size 0x2, 16-bit address decoding



Comment 3 Brent Fox 2002-11-22 18:27:09 UTC

*** This bug has been marked as a duplicate of 72045 ***

Comment 4 Guido 2002-11-25 07:13:47 UTC
So, after reading bug 75014, I understand that the problem is in redhat-config-
soundcard, but:

- no solution is provided in redhat;
- no suggest is given for other possible solutions.

Very, very well...



Comment 5 Brent Fox 2002-11-26 16:14:18 UTC
guidorocca, you should be able to use sndconfig to configure your ISA soundcard.
 I apologize for any misunderstanding, but redhat-config-soundcard currently
only supports PCI soundcards.  

It's not that I don't want to support ISA cards, but I'm trying to be honest
about what I can realistically accomplish in the time between now and the next
release.  As I said, sndconfig should configure most ISA cards properly.

Comment 6 Guido 2002-12-10 16:42:58 UTC
Sorry, I misunderstood. 

I supposed that redhat-config-soundcard was the only way to get a sound while 
running X.

I have used aumix and now I can hear sounds.

Sorry again

    Guido


Note You need to log in before you can comment on or make changes to this bug.