Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 74989 - OSError: Too many open files
Summary: OSError: Too many open files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhpl
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
: 75357 75968 76202 77092 77419 77573 79939 80548 81055 84198 85492 87470 87935 99367 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-03 13:15 UTC by Need Real Name
Modified: 2007-04-18 16:47 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-08 14:55:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2002:225 normal SHIPPED_LIVE Updated rhpl packages fixes file descriptor leak 2003-09-24 04:00:00 UTC

Description Need Real Name 2002-10-03 13:15:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start redhat-config-network
2. go get some coffee
3. (20 mins later) This traceback has popped up.
	

Actual Results:  Traceback (most recent call last):
  File "/usr/sbin/neat", line 774, in update_devicelist
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Control.py", line
63, in __init__
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Control.py", line
66, in load
OSError: Too many open files


Additional info.. dunno if its relevant.

[root@daysleeper cipe]# cat /proc/sys/fs/file-max
26205
[root@daysleeper cipe]# cat /proc/sys/fs/file-nr
3307    69      26205
[root@daysleeper cipe]# cat /proc/sys/fs/inode-nr
5162    2084


Additional info: Complete fresh 8.0 install

Comment 1 Josiah Royse 2002-10-03 15:01:30 UTC
Using the above information, this is an easy demonstration of the problem:

1. watch -d cat /proc/sys/fs/file-nr /proc/sys/fs/inode-state /proc/sys/fs/inode-nr

2. redhat-config-network

Comment 2 Harald Hoyer 2002-10-08 14:55:30 UTC
*** Bug 75357 has been marked as a duplicate of this bug. ***

Comment 3 Harald Hoyer 2002-10-08 14:56:35 UTC
fixed in >= rhpl-0.54-1
there will be a bugfix errata

Comment 4 Harald Hoyer 2002-10-15 11:04:49 UTC
*** Bug 75968 has been marked as a duplicate of this bug. ***

Comment 5 Harald Hoyer 2002-10-18 15:06:59 UTC
*** Bug 76202 has been marked as a duplicate of this bug. ***

Comment 6 Harald Hoyer 2002-11-04 12:45:56 UTC
*** Bug 77092 has been marked as a duplicate of this bug. ***

Comment 7 Harald Hoyer 2002-11-07 06:52:48 UTC
*** Bug 77419 has been marked as a duplicate of this bug. ***

Comment 8 Harald Hoyer 2002-11-11 10:09:53 UTC
*** Bug 77573 has been marked as a duplicate of this bug. ***

Comment 9 Harald Hoyer 2003-01-09 14:16:12 UTC
*** Bug 80548 has been marked as a duplicate of this bug. ***

Comment 10 Harald Hoyer 2003-01-09 14:16:40 UTC
*** Bug 81055 has been marked as a duplicate of this bug. ***

Comment 11 Harald Hoyer 2003-01-09 14:37:58 UTC
*** Bug 79939 has been marked as a duplicate of this bug. ***

Comment 12 Harald Hoyer 2003-02-13 14:40:44 UTC
*** Bug 84198 has been marked as a duplicate of this bug. ***

Comment 13 Harald Hoyer 2003-03-10 14:07:21 UTC
*** Bug 85492 has been marked as a duplicate of this bug. ***

Comment 14 Harald Hoyer 2003-03-31 16:03:48 UTC
*** Bug 87470 has been marked as a duplicate of this bug. ***

Comment 15 Harald Hoyer 2003-04-04 03:22:59 UTC
*** Bug 87935 has been marked as a duplicate of this bug. ***

Comment 16 Harald Hoyer 2003-08-05 07:59:50 UTC
*** Bug 99367 has been marked as a duplicate of this bug. ***

Comment 17 Harald Hoyer 2003-09-24 22:56:52 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2002-225.html


Comment 18 Need Real Name 2003-09-25 15:18:53 UTC
Good QA work, bugfix errata released ONE YEAR after the fix... :-(( 
 
I sure hope this is a mistake, and not how it's supposed to work. 

Comment 19 Harald Hoyer 2003-09-26 08:59:33 UTC
yes, this hung around in the queue and was forgotten to be pushed out... by
me... :-/ shame on me...


Note You need to log in before you can comment on or make changes to this bug.