Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 74862 - dhclient.conf is not used in ifup
Summary: dhclient.conf is not used in ifup
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-02 12:29 UTC by Eli Barzilay
Modified: 2014-03-17 02:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-29 20:16:55 UTC


Attachments (Terms of Use)

Description Eli Barzilay 2002-10-02 12:29:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
ifup only uses /etc/dhclient-${DEVICE}.conf.  One thing is that it is
useful to have a global conf file, and anoher is that the dhclient man
page mentions /etc/dhclient.conf.  So it is probably a good idea to
use that file, maybe just append it to dhclient-${DEVICE}.conf.
(This is related to the dhclient package which is not on the list).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Edit dhclient.conf
2. Put on a surprised face when it doesn't work


Additional info:

Comment 1 Elliot Lee 2002-10-13 16:04:08 UTC
Probably not possible to merge config files - just concatenating them is not likely to 
produce a correct result.

In any case, this is an initscripts issue :)

Comment 2 Eli Barzilay 2002-10-13 17:00:32 UTC
It looks like it should be possible to merge the config file by concatenation,
as long as each file contains full information.  The thing is that I was locked
between either using PEERDNS (getting a close nameserver but a useless SEARCH
in the domain of my home ISP) or not using it (locking myself with a single set
of nameservers but being able to specify my search domains).  (Using the
LOCALDOMAIN environment variable is only a a partial solution since some
programs (like ping) won't use it.)

The dhclient.conf is an ideal place for that configuration -- I can use
  append domain-name-servers ...,...;
  supersede domain-name "... ...";
to add some nameservers if the ISP gives too little, and always use my search
domains.  But a setting like this is something I use either on a wire (eth0) or
on wireless (eth1) -- the current setup forces me to have an identical file
(which I manage as the same file using symlinks), but it would be better to
leave this in dhclient.conf and concatenate that before any additional settings
that might appear in dhclient-eth*.conf.

The current setup is made worse by the man page which doesn't say anything
about dhclient-eth*.conf, which means that the only way I could discover this
was dig my way through the scripts.

I don't know who if initscripts is a redhat thing or not, so sorry if this is
the wrong place...


Comment 3 Bill Nottingham 2005-09-29 20:16:55 UTC
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.


Note You need to log in before you can comment on or make changes to this bug.