Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7474 - recording sound with a opl3sax card does not work.
Summary: recording sound with a opl3sax card does not work.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-01 10:59 UTC by gerald
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-14 01:42:13 UTC


Attachments (Terms of Use)

Description gerald 1999-12-01 10:59:54 UTC
I have an ASUS 7300 laptop with an opl3-sax card by Yamaha.
I am pretty sure that sound is set up correctly.
Here is the relevant part of my /etc/conf.modules:
----------------------------------------------------------------------
alias sound opl3sa2
pre-install sound /sbin/insmod sound dmabuf=1
alias midi opl3
options opl3 io=0x388
options opl3sa2 mss_io=0x530 irq=5 dma=0 dma2=7 mpu_io=0x330 io=0x370
----------------------------------------------------------------------

and here is the content of /proc/sound:
----------------------------------------------------------------------
OSS/Free:3.8s2++-971130
Load type: Driver loaded as a module
Kernel: Linux soliton 2.2.13 #1 Tue Oct 26 14:33:48 MEST 1999 i686
Config options: 0

Installed drivers:

Card config:

Audio devices:
0: MS Sound System (CS4231) (DUPLEX)

Synth devices:
0: Yamaha OPL3

Midi devices:
0: MPU-401 0.0  Midi interface #1

Timers:
0: System clock
1: MS Sound System (CS4231)

Mixers:
0: OPL3-SAx and AD1848 (through MSS)
1: MS Sound System
(CS4231)
----------------------------------------------------------------------

Playing sound (au,mp3,midi0) works fine. However, recording sound does
not work properly. I tried to use rec (from sox) and krecord (for kde).
I can record sound, but the signal is totally disorted and there is
so much noise that the result is useless. I tried mono/stereo, different
sampling rates, but to no avail.

Recording sound under windows works, so it is not a hardware problem.
Recording sound with rec/krecord on a diferent laptop with an ess card
also works fine.

Comment 1 Cristian Gafton 2000-01-04 22:25:59 UTC
Assigned to dledford

Comment 2 Alan Cox 2002-12-14 01:42:13 UTC
Seems to work on newer Linuxes at least, if not re-open



Note You need to log in before you can comment on or make changes to this bug.