Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7455 - /usr does not unmount
Summary: /usr does not unmount
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On: 7489
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-30 22:17 UTC by Geoff Reedy
Modified: 2014-03-17 02:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-18 20:21:25 UTC


Attachments (Terms of Use)

Description Geoff Reedy 1999-11-30 22:17:03 UTC
With initscripts-4.68 /usr will not unmount properly on halt/reboot.  At
the end of the shutdown sequence it says:

Turning off swap OK
Turning off accounting OK
Turning off quotas OK
Unmounting file systems umount2: Device of resource busy
umount: /usr: device is busy FAILED
INIT: no more processes left in the runlevel

and then hangs, the strange thing is that I don't have this problem on
another computer with very simillar configuration.

Comment 1 Bill Nottingham 1999-12-01 16:07:59 UTC
Does this only happen with 4.68 for you as opposed
to earlier/later errata releases?

Comment 2 Geoff Reedy 1999-12-01 17:56:59 UTC
I've had this problem ever since upgrading to 6.1

The problem is that fuser kills some stuff that shouldn't be killed.
I put in a fuser -v -m /usr to see what was getting killed.  It reported that
both rc and S01halt were using /usr.

After a little further investigation I figured out the whole of the problem:

These machines use LDAP for authentication, so ldap is in /etc/nsswitch.conf.
The libc loads the ldap library which is installed in /usr/lib.  As a result
every process depends on /usr.  So I guess this is really a bug with the
openldap rpm in that it should install libldap to /lib.

Comment 3 Bill Nottingham 2000-01-18 20:21:59 UTC
This is fixed in the nss_ldap RPMs in Raw Hide.


Note You need to log in before you can comment on or make changes to this bug.