Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 74511 - Nautilus crashes while scrolling large directories
Summary: Nautilus crashes while scrolling large directories
Keywords:
Status: CLOSED DUPLICATE of bug 73733
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86
Version: null
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-25 17:54 UTC by earthdog
Modified: 2015-01-08 00:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-09-29 17:23:50 UTC


Attachments (Terms of Use)

Description earthdog 2002-09-25 17:54:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
Whn scrolling large directories, nautilus will simply stop responding and cause
the X server to lock up completely.  The mouse will still function, but the rest
of the server is simply dead.  This happens also when dragging another gnome2
application across a nautilus window, especially Pan (sometimes Pan causes this
same crash or one similar on it's own) and gEdit.  It is bad enough that the
Gnome environment is almost unusable on this system.  I am new to this bug
reporting thing, so please tell me if you need any log files, outputs, etc.  I
will be happy to help.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Open Nautilus window,
2.  Open /usr/lib/,
3.  Scroll through the directory quickly using mousewheel or scroll bar.

-or-

1.  Open nautilus window to a large dir,
2.  Open Pan,
3.  Move the Pan window over the top of the nautilus window,
4.  Or do the same with a gEdit window
	

Actual Results:  Xserver locks, unable to bail out of it or switch to another
virtual console.  Mouse still moves in Xserver.

Expected Results:  Nothing.  System should function as expected (ie - display
files/folders, not lock up in general).

Additional info:

Athlon T-bird 1.1 gHz
Shuttle MB
GF2mx100 PCI video card
Nvidia drivers v.1.0-3123
20 gig Maxtor HD
Sony CDRW
Linksys ethernet
256 mb PC-133 RAM
USB Logitech wheelmouse

All components were detected at install w/o any problems.  All components have
functioned very well on past versions of Redhat Linux, again w/o any problems. 
It should be noted that this problem was observed in the 9.0rc2 beta of Mandrake
Linux (exactly the same when using gnome2 desktop).

Comment 1 Havoc Pennington 2002-09-25 18:40:31 UTC
If I understand correctly, Nautilus hasn't crashed, X has locked up. 
X server lockups are X server bugs, applications should not be able to lock 
the server.

Comment 2 earthdog 2002-09-25 18:55:55 UTC
I am not sure if Nautilus crashed or not, honestly.  I know that the problem
seems to reproduce every time if Nautilus is open/being used.  This led me to
believe that Nautilus/gtk2/gnome2 were the culprits.  Is there a log file or
anything I can send that will help?

Comment 3 earthdog 2002-09-25 21:27:38 UTC
I have run xf86config and hand edited XF86Config afterwards.  Crashes still happen.

Also, the crashes are reproducable with gnome2/gtk2 apps while running under
KDE.  Specifically, gedit and Pan.

Comment 4 Mike A. Harris 2002-09-29 17:23:12 UTC
Red Hat does not support Nvidia binary only drivers.

*** This bug has been marked as a duplicate of 73 ***

Comment 5 Mike A. Harris 2002-09-29 17:24:17 UTC

*** This bug has been marked as a duplicate of 73733 ***

Comment 6 Mike A. Harris 2002-09-29 17:25:01 UTC
If you have any lockups or problems while using Nvidia's drivers, contact
Nvidia and provide them with a bug report so they can fix their drivers.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.