Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 74320 - Static routes cannot be added easily anymore
Summary: Static routes cannot be added easily anymore
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 8.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
: 75604 76619 82834 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-20 12:28 UTC by Jos Vos
Modified: 2014-03-17 02:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-12 06:40:31 UTC


Attachments (Terms of Use)

Description Jos Vos 2002-09-20 12:28:17 UTC
Description of Problem:
The ifup-routes scripts does *not* look at the network-scripts/route-$DEVICE
file anymore, *unless* a file networking/devices/$DEVICE.route exists.  This
makes it very difficult to easily add manual static routes by just putting them
in a file, like static-routes or route-$DEVICE.

Version-Release number of selected component (if applicable):
6.95-1

Workaround (only done a few tests):
Touch the networking/devices/$DEVICE.route, so that
network-scripts/route-$DEVICE is interpreted correctly.

Proposed fix:
Process the network-scripts/route-$DEVICE file before the
networking/devices/$DEVICE.route file is processed.

Comment 1 Bill Nottingham 2002-11-12 06:40:19 UTC
*** Bug 76619 has been marked as a duplicate of this bug. ***

Comment 2 Bill Nottingham 2002-11-12 06:40:22 UTC
*** Bug 75604 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2002-11-12 06:42:08 UTC
Fixed in CVS, will be in 6.96-1

Comment 4 Bill Nottingham 2003-01-27 17:47:07 UTC
*** Bug 82834 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.