Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7424 - kudzu can somehow corrupt ld.so.cache when installing bad hardware
Summary: kudzu can somehow corrupt ld.so.cache when installing bad hardware
Keywords:
Status: CLOSED DUPLICATE of bug 6667
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu
Version: 6.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-29 22:41 UTC by kucharsk
Modified: 2014-03-17 02:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-05 19:58:57 UTC


Attachments (Terms of Use)

Description kucharsk 1999-11-29 22:41:02 UTC
Don't ask me HOW this happened, I just know I was able to recreate it
TWICE.

I was attempting to install a 100BaseT PCI Intel EEPRO card I later found
out was bad.

When kudzu tried to install the card, it somehow corrupted ld.so.cache such
that any program linked with shared libraries would die with an assertion
failure.

To recover, I had to reset the machine, boot "linux single" and re-run
ldconfig by hand.

While this is a severe bug, I'm giving it low severity as if it were common
I suspect it would have already been reported here...

Comment 1 Bill Nottingham 2000-02-05 19:58:59 UTC
*** This bug has been marked as a duplicate of 6667 ***


Note You need to log in before you can comment on or make changes to this bug.