Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 74206 - redhat-config-date & time will fail.
Summary: redhat-config-date & time will fail.
Keywords:
Status: CLOSED DUPLICATE of bug 76313
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-date
Version: null
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-17 21:15 UTC by Ivo Sarak
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-01 18:55:26 UTC


Attachments (Terms of Use)

Description Ivo Sarak 2002-09-17 21:15:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
When to run redhat-config-samba it will fail.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
run redhat-config-samba as root.

Actual Results:  

[root@haskaa root]# redhat-config-time
Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 35, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 179, in __init__
    self.timezonePage = timezone_gui.timezonePage()
  File "/usr/share/redhat-config-date/timezone_gui.py", line 50, in __init__
    self.tz = TimezoneMap(zonetab, self.default, map=path)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 139, in __init__
    self.setCurrent(self.currentEntry)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 180, in setCurrent
    self.markers[self.currentEntry.tz].hide()
AttributeError: 'NoneType' object has no attribute 'tz'
[root@haskaa root]# redhat-config-date
Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 35, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 179, in __init__
    self.timezonePage = timezone_gui.timezonePage()
  File "/usr/share/redhat-config-date/timezone_gui.py", line 50, in __init__
    self.tz = TimezoneMap(zonetab, self.default, map=path)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 139, in __init__
    self.setCurrent(self.currentEntry)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 180, in setCurrent
    self.markers[self.currentEntry.tz].hide()
AttributeError: 'NoneType' object has no attribute 'tz'
[root@haskaa root]#

Expected Results:  Some date/time configuration menus, maybe?

Additional info:

Comment 1 Brent Fox 2002-09-30 20:18:23 UTC
I'm not sure I understand.  You say to run redhat-config-samba, but the
traceback is from redhat-config-date.  Can you clarify?

Comment 2 Ivo Sarak 2002-09-30 20:44:22 UTC
My wrong, I was using previous bugreport form and forgot to update description 
field. 

Instead of:

"Description of problem:
When to run redhat-config-samba it will fail."

there must be:

"Description of problem:
When to run redhat-config-date or redhat-config-time it will fail."


Comment 3 Tom Wood 2002-10-01 18:55:20 UTC
Whoops!  This same error can be found in RH 8.0 as downloaded from RHN (isos).

Comment 4 Brent Fox 2002-10-22 16:05:31 UTC
This is a dupe of bug 76313

*** This bug has been marked as a duplicate of 76313 ***


Note You need to log in before you can comment on or make changes to this bug.