Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7418 - loading of mixer settings is not correctly displayed
Summary: loading of mixer settings is not correctly displayed
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-29 20:49 UTC by dim
Modified: 2014-03-17 02:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-29 21:46:15 UTC


Attachments (Terms of Use)

Description dim 1999-11-29 20:49:35 UTC
Although bug7366 fixes the incorrect if syntax, to enable loading of the
mixer settings, the process is not displayed in the normal manner.
This is because the line that actually loads the settings says:

action "Loading mixer settings" /bin/aumix-minimal -f /etc/.aumixrc -L
>/dev/null

which causes also the [OK] message, generated by the action function, to go
to /dev/null, which is probably not what was intended. The simplest fix is
to just remove the ">/dev/null" part. You could also try stuff like

action "Loading mixer settings" '/bin/aumix-minimal -f /etc/.aumixrc -L
>/dev/null'

but I'm not sure if this will work correctly.

Comment 1 Bill Nottingham 1999-11-29 21:46:59 UTC
Actually, you can just take out the redirect to /dev/null.
Fixed in initscripts-4.70-1.


Note You need to log in before you can comment on or make changes to this bug.