Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7408 - Problem with ispell language packages
Summary: Problem with ispell language packages
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ispell
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-29 10:33 UTC by mazet
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-30 16:07:20 UTC


Attachments (Terms of Use)

Description mazet 1999-11-29 10:33:13 UTC
Helo every body

I try to install different ispell language packages (ispell-french,
ispell-german, ispell-spanish and ispell-italian). There was no errror
reported during the install but, I do not found any new dictionnaries
in /usr/lib/ispell. I check in the rpm database and get :
> rpm -qs ispell-french
normal        /usr/doc/ispell-french-3.1.20
normal        /usr/doc/ispell-french-3.1.20/COPYING
normal        /usr/doc/ispell-french-3.1.20/ChangeLog
normal        /usr/doc/ispell-french-3.1.20/LISEZMOI
normal        /usr/doc/ispell-french-3.1.20/MANIFEST
not installed /usr/lib/ispell/francais.aff
not installed /usr/lib/ispell/francais.hash

Does any one have any idea to solve this trouble ?

Bye

    Laurent

Comment 1 Michael K. Johnson 1999-11-30 16:07:59 UTC
These files are tagged by language, and rpm will only install such
files if the language in use on the system matches.  You can install
all the files with
LINGUAS=all rpm -Uvh ispell-<language>*rpm --force

The tags were causing more confusion than they were worth in the
language-specific ispell dictionary packages and so have been removed
from those packages for our next release.

Comment 2 Rick van Rein 2000-01-27 22:26:59 UTC
It may be obvious from the many complaints that the language selection is
somewhat counter-intuitive :-)
When I learnt the cause of the trouble, I was surprised in three ways:
 (1) that RedHat has found yet another smart/practical thing to put into RPM
 (2) that it was applied to packages whose names already imply a lang choice
 (3) that is was *not* applied to stuff with locale entries
	I currently have 111 languages and flavours of them installed.
	(And I only speak 3 and understand up to 5!)


Note You need to log in before you can comment on or make changes to this bug.