Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7380 - installer trouble
Summary: installer trouble
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-27 22:54 UTC by imcmeans
Modified: 2015-01-07 23:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-29 12:20:16 UTC


Attachments (Terms of Use)

Description imcmeans 1999-11-27 22:54:01 UTC
Hey. I run autoboot.bat in the dosutils folder of the i386 release of
redhat 6.1. When I run the dos installer (gui), I set up everything as far
as user privelages, when it lists this in an exception window:

traceback (innermost, last):
File "/usr/bin/anaconda.real",
   line 225, in ?
   intf.run(todo, test = test)
File "/tmp/lib/python1.5/site-packages/text.py", line 1000, in run
   rc= apply(step[1](), step[2])
File "/tmp/lib/python1.5/site-packages/text.py", line 468, in __call__
   todo.getcompslist()
File "/tmp/lib/python1.5/site-packages/todo.py", line 942, in getcompslist
   self.getheaderlist()
File "/tmp/lib/python1.5/site-packages/todo.py", line 930, in get
headerlist
   self.hdlist =
   self.method.readheaders()
File "/tmp/lib/python1.5/site-packages/harddrive.py", line 46, in
readheaders
   return HeaderList(hl)
File
   "/tmp/lib/python1.5/site-packages/comps.py", line 50, in __init__
   name = h[rpm.rpmtag_name]
typeError: unsubscribable object


I copied this out by hand, and so there might be some spelling mistakes. I
tried to start the install by floppy disk using the errata .img updates,
but my computer won't boot to the floppies. (although it will boot to
other floppies). I dont know what to do, any help would be greatly
appreciated. email imcmeans@home.com

Comment 1 Jay Turner 1999-11-29 12:20:59 UTC
This bug is more than likely a result of having a file in the /RedHat/RPMS
directory which is not actually an *.rpm file.  If you copied the files from a
cdrom, then the file causing the problem is one called "TRANS.TBL"

Run "ls | grep -v rpm" in the /RedHat/RPMS directory in order to get a list of
the non-RPM files which are causing the problem.


Note You need to log in before you can comment on or make changes to this bug.