Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7374 - cann't unmount / cleanly during the rebooting process
Summary: cann't unmount / cleanly during the rebooting process
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libc
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-27 11:12 UTC by karlsl
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-06 21:09:08 UTC


Attachments (Terms of Use)

Description karlsl 1999-11-27 11:12:59 UTC
I see this message, "unmount: / is busy" whenever I try to reboot the
computer.

Comment 1 Thomas Hansen 1999-12-23 10:55:59 UTC
Hi RedHat,

I have exactly the same problem, but only on my IBM computer's with normal scsi
disks. I also have an IBM with serveraid installed and the problem is not there
at all. On one Dell server is not there either.
This is a transcript of an reboot:
[root@lxas1 /root]# reboot
Stopping keytable
Shutting down X Font Server:
Stopping gpm
Shutting down PCNFSD daemon:
Shutting down sendmail:
Shutting down SMB services:
Shutting down NMB services:
Shutting down named:
Stopping INET services:
Stopping at daemon:
Stopping cron daemon:
Stopping lpd
Unmounting NFS filesystems
Saving random seed
Stopping portmap services:
Shutting down interface eth0
Disabling IPv4 automatic defragmentation
Shutting down kernel logger:
Shutting down system logger:]
Starting killall rpc.statd forgot to set AF_INET in udp sendmsg. Fix it!

Sending all processes the TERM signal
Sending all procmd: recovery thread got woken up ...
esses the KILL smd: recovery thread finished ...
ignal.. mdrecoveryd(6) flushing signals.

Turning off swap
Turning off accounting
Unmounting proc file system
mount: / is busy
Error: /proc must be mounted
  To mount /proc at boot you need an /etc/fstab line like:
      /proc   /proc   proc    defaults
  In the meantime, mount /proc /proc -t proc
mount: / is busy
Please stand by while rebooting the system...
stopping all md devices.

Restarting system.

LILO boot:
Loading linux..................
INIT: version 2.77 booting
			Welcome to _[1;31mRed Hat_[0;39m Linux
		Press 'I' to enter interactive startup.
Mounting proc filesystem
Setting clock : Thu Dec 23 11:44:36 CET 1999
Loading default keymap
Activating swap partitions
Setting hostname lxas1
Checking root filesystem
/dev/sda1 was not cleanly unmounted, check forced.
/dev/sda1:

etc

Comment 2 Cristian Gafton 2000-01-06 21:09:59 UTC
You must have modfied some of your initscripts that cause /proc to be unmounted
prematurely and in turn the final shutdown steps are not performed cleanely.


Note You need to log in before you can comment on or make changes to this bug.