Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 73398 - Panel segs after customization
Summary: Panel segs after customization
Keywords:
Status: CLOSED DUPLICATE of bug 75138
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-panel
Version: 8.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL: na
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-09-04 03:37 UTC by qwnsknight
Modified: 2007-04-18 16:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:49:34 UTC


Attachments (Terms of Use)

Description qwnsknight 2002-09-04 03:37:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
On 2 different systems using default Gnome desktop, when changes are made to
panel (ie. setting it to a right side vertical panel instead of a horizontal
bottom panel) it segs on sub-sequent launches of X11.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Verify default Gnome desktop for "Joe User"
2.Right click properties on panel.
3.Set panel to go to the right side of the desktop.
4.Exit X
5.Login as Joe
6.Experience problem.
7.Document facts
8.Submit bug
	

Actual Results:  Gnome detected crash with panel and wanted to file a bug report.

Expected Results:  Panel should have ran and life with linux would be harmonious.

Additional info:

output from manual running gnome-panel after stopping gnome-session from
spawning gnome-panel.
--------------------------
$gnome-panel

system-tray-applet-ERROR **: file obox.c: line 107 (get_class): should not be
reached
aborting...
---------------------------------

Comment 1 qwnsknight 2002-09-04 03:49:23 UTC
Set this to High because the gnome-desktop will be totally useless to first time
linux users, and also because panel does crash.

Comment 2 Havoc Pennington 2002-09-04 04:20:00 UTC
Can you upgrade to gnome-panel 2.0.6-9 or newest available in rawhide, and be
sure this bug still exists?

Comment 3 qwnsknight 2002-10-03 19:43:55 UTC
Sorry, I did not get a chance to upgrade to the latest rawhide.
Though I have upgraded to RedHat release 8.0. The exact error is still there.
I did complete the bug submit through "bug buddy", so look for duplicate.

Comment 4 Havoc Pennington 2002-10-03 19:57:46 UTC
Yes, sorry, this definitely exists in final. It's fixed in system-tray-applet in
GNOME CVS.

Comment 5 Havoc Pennington 2003-01-08 03:22:42 UTC

*** This bug has been marked as a duplicate of 75138 ***

Comment 6 Corey Bissaillon 2003-09-25 20:10:37 UTC
As a workaround,  I:
1) Removed  .gconfd/lock/ directory (which caused gnome-panel to generate it's
own -funky- panel at the top of the screen).

2)Copied the
/root/.gconf/apps/panel/profiles/default/panels/bottom_panel/%gconf.xml  to
overwrite the corresponding file in my non-super-user's path.  

After restarting X, gnome-panel no longer crashed, and in fact was replaced with
the custom launchers I had defined intact.  

That's all I had time for... hope this input helps to track it down!   

 



Comment 7 Red Hat Bugzilla 2006-02-21 18:49:34 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.