Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 73230 - up2date hangs during update with SSL error
Summary: up2date hangs during update with SSL error
Keywords:
Status: CLOSED DUPLICATE of bug 69781
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: rhnlib
Version: null
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-01 11:44 UTC by Pavel
Modified: 2015-01-08 00:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-09-12 21:52:37 UTC


Attachments (Terms of Use)

Description Pavel 2002-09-01 11:44:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020831

Description of problem:
I'm using up2date-2.9.61-1 from rawhide.
During a long update, the application got stuck, with following traceback:
Traceback (most recent call last):  File "/usr/share/rhn/up2date_client/gui.py",
line 1409, in doRetrieval
    self.setRetrievalProgress)
  File "/usr/share/rhn/up2date_client/up2date.py", line 255, in getPackage
    buffer = rpcServer.doCall(rpmSource.psc.packageSource.getPackage, pkg,
msgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 110, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 215, in getPackage
    package = source.getPackage(pkg, MsgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 685, in getPackage
    fd = self.s.getPackage(channel, filename)
  File "/usr/lib/python2.2/xmlrpclib.py", line 821, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 126, in _request
    verbose=self._verbose
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 118, in request
    headers, fd = req.send_http(host, handler)
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 602, in send_http
    headers=self.headers)
  File "/usr/lib/python2.2/httplib.py", line 537, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib/python2.2/httplib.py", line 553, in _send_request
    self.putrequest(method, url)
  File "/usr/lib/python2.2/httplib.py", line 453, in putrequest
    self.send(str)
  File "/usr/lib/python2.2/httplib.py", line 407, in send
    self.sock.sendall(str)
  File "/usr/lib/python2.2/site-packages/rhn/SSL.py", line 196, in write
    sent = self._connection.send(data)
SSL.Error: [('SSL routines', 'SSL23_WRITE', 'ssl handshake failure')]

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Run up2date when lot of packages available
2.
3.
	

Actual Results:  Stops with traceback after downloading some packages

Expected Results:  Finish downloading successfully

Additional info:

Comment 1 Michael Young 2002-09-01 13:41:01 UTC
Similar to Bug 69781?

Comment 2 Pavel 2002-09-01 13:47:24 UTC
Looks the same. I used null version for search so I missed that report.

Comment 3 Adrian Likins 2002-09-12 21:52:03 UTC
reassigning to rhnlib

Comment 4 Mihai Ibanescu 2002-09-13 14:18:12 UTC

*** This bug has been marked as a duplicate of 69781 ***


Note You need to log in before you can comment on or make changes to this bug.