Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 73027 - incorrect dependency on libgd breaks apache
Summary: incorrect dependency on libgd breaks apache
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php
Version: 7.3
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
: 78696 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-30 00:45 UTC by Ganesh Sittampalam
Modified: 2007-04-18 16:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-04-05 12:39:34 UTC


Attachments (Terms of Use)

Description Ganesh Sittampalam 2002-08-30 00:45:17 UTC
Description of Problem:
There should be a dependency on libgd.so.1.8.4 (or the gd-1.8.4 
package) - with gd-1.8.3 /usr/lib/apache/libphp4.so has an unresolved symbol (I ran into this 
trying to upgrade slowly and carefully from RH7.1 to RH7.3)

Version-Release number of 
selected component (if applicable):
php-4.1.2-7.3.4 and gd-1.8.3-7

How 
Reproducible:
Install these packages

Steps to Reproduce:
Start Apache

Actual 
Results:
Apache fails to load libphp4.so, complaining about unresolved symbol 
gdStringFT

Expected Results:
Apache should have loaded

Additional 
Information:
I don't know if the procedure of upgrading Redhat versions bit by bit is 
officially "supported", but it is absolutely essential for upgrading a server while trying to 
keep services running as much as possible,

Comment 1 Phil Copeland 2002-08-30 01:44:29 UTC
gdStringFT ? never heard of it. Doesn't even exist in the gd libs

[root@dhcp59-221 root]# nm  /usr/lib/libgd.* | grep -ic gdStringFT
0

[root@alpha php-4.1.2]# grep -irc gdStringFT *
0

Not directly referanced by anything in the php codebase either.
google has never heard of it either...

Sorry, I can find no referance to this gdStringFT in the codebase.

Oh wait, you did a jump from 7.1 to 7.3? how as an upgrade install? As a rpm
-Fvh against an RPMS directory?





Comment 2 Ganesh Sittampalam 2002-08-30 01:50:00 UTC
Sorry, my mistake, that should be gdImageStringFT. It's in the 7.3 version of gd but not the 7.1 
version.

I upgraded by manually upgrading small dependency groups of RPMs at a time 
(actually using apt-rpm, but that just calls rpm -U to do its work).

Comment 3 Phil Copeland 2002-08-30 02:59:26 UTC
Ok so it's a BuildRequires: gd >= 1.8
it's added for errata but for now as you've already seen, just update gd


Phil
=--=

Comment 4 Ganesh Sittampalam 2002-08-30 03:05:38 UTC
surely it's "Requires: gd >= 1.8.4"? I wasn't trying to build it and the difference between 1.8.3 
and 1.8.4 is significant, since it's in 1.8.4 that the symbol appears.

Comment 5 Phil Copeland 2002-08-30 04:47:57 UTC
yes, sorry, not getting enuf sleep here...


Comment 6 Joe Orton 2002-09-26 08:51:26 UTC
Leaving this open whilst an errata is still pending.

Comment 7 Joe Orton 2002-11-29 17:25:25 UTC
*** Bug 78696 has been marked as a duplicate of this bug. ***

Comment 8 Joe Orton 2002-11-29 19:29:53 UTC
*** Bug 78696 has been marked as a duplicate of this bug. ***

Comment 9 Joe Orton 2004-04-05 12:39:34 UTC
Thanks for the reports.  This is fixed in all current releases.


Note You need to log in before you can comment on or make changes to this bug.