Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7299 - backpack cdrom not recognized.
Summary: backpack cdrom not recognized.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mount
Version: 6.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-24 17:53 UTC by jmannion
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-05 07:20:16 UTC


Attachments (Terms of Use)

Description jmannion 1999-11-24 17:53:03 UTC
I know that this is probably not a bug, more likely my own ignorance, but
I cannot get Red Hat 6.0 to recognize my Backpack cdrom after the initial
install. The installation goes fine, parallel port cdrom recognized from
the boot.img disk, no problems, but when I try to mount the cdrom
(mount  /dev/cdrom  /mnt/cdrom) after the install, I get the msg: you must
specify filesystem.

So I type:

mount  -t iso9660  /dev/cdrom  /mnt/cdrom

and I get the msg: the cdrom does not exist.

Then, I go into /etc/fstab and change the line:

/dev/cdrom  /mnt/cdrom  iso9660 noauto, ro 0 0

to:

/dev/bpcd /mnt/cdrom iso9660 noauto, ro 0 0

then at the command line I type:

mount  /dev/bpcd  /mnt/cdrom

and I get this msg:

you must specify file system

so I type:

mount  -t  /dev/bpcd  /mnt/cdrom

and I get this msg:

the kernel does not recognize /dev/bpcd ad a block device(maybe 'insmod
driver'?)

Any help would be greatly appreciated, the Red Hat user list has not been
able to help me up to this point. I am concerned that I may have the same
situation with Red Hat 6.1 that I am waiting on a boot.img disk that
supports parallel port cdroms.

Thank You,

John Mannion

Comment 1 Riley H Williams 1999-11-24 18:06:59 UTC
Remembering that the backpack plugs into the parallel port as a PARIDE unit, I
would suspect that you will need to enable and load the paride subsystem. If so,
try the following commands:

    modprobe paride
    modprobe pf

When you've done that, retry your mount command - it should now work.

Comment 2 jmannion 1999-11-24 23:02:59 UTC
I have tried the commands you gave me: modprobe paride
                                       modprobe pf

When I type in modprobe pf I get this message:

/lib/modules/2.2.5-15/misc/pf.0:init_module:device or resource busy

problem?

Thanks,

John Mannion

Comment 3 Bernhard Rosenkraenzer 1999-11-28 13:24:59 UTC
The error message looks like the IRQ (or parallel port) is already in use
by another device.
Check the BIOS settings for the parallel port.

Comment 4 jmannion 1999-11-30 14:43:59 UTC
I have checked my bios for interrupt conflicts, none exist. Com1 has irq 4 and
my parallel port irq is set to 7.

John Mannion

Comment 5 Bernhard Rosenkraenzer 1999-11-30 16:11:59 UTC
I presume adding
	alias paride_protocol pf
to /etc/conf.modules
doesn't fix the problem either?

Comment 6 jmannion 1999-12-01 20:35:59 UTC
You are correct, nothing seems to be working.

John M.

Comment 7 jmannion 1999-12-16 18:31:59 UTC
You can close this "bug". I have resolved my parallel port cdrom issue.

Thank You


Note You need to log in before you can comment on or make changes to this bug.