Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7270 - syntax error in setsysfont portion of initscripts-4.67-1 (with fix)
Summary: syntax error in setsysfont portion of initscripts-4.67-1 (with fix)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
: 7285 7410 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-24 02:24 UTC by mashton
Modified: 2014-03-17 02:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-24 04:31:48 UTC


Attachments (Terms of Use)

Description mashton 1999-11-24 02:24:21 UTC
bug shows up as "[: argument expected" on bootup.

from /etc/rc.d/rc.sysinit:
Is:

# Load system font
if [ -x /sbin/setsysfont ]; then
    [ -f /etc/sysconfig/i18n ] && . /etc/sysconfig/i18n
    if [ -f /etc/sysconfig/console/$SYSFONT.psf.gz -o \
         -f /usr/lib/kbd/consolefonts/$SYSFONT.psf.gz -o \
         -f /etc/sysconfig/console/$SYSFONT.gz -o \
         -f /usr/lib/kbd/consolefonts/$SYSFONT.gz -o ]; then
--- problem is here ------------------------------^^^

should be:

# Load system font
if [ -x /sbin/setsysfont ]; then
    [ -f /etc/sysconfig/i18n ] && . /etc/sysconfig/i18n
    if [ -f /etc/sysconfig/console/$SYSFONT.psf.gz -o \
         -f /usr/lib/kbd/consolefonts/$SYSFONT.psf.gz -o \
         -f /etc/sysconfig/console/$SYSFONT.gz -o \
         -f /usr/lib/kbd/consolefonts/$SYSFONT.gz ]; then


did no one even boot this??

Comment 1 Bill Nottingham 1999-11-24 04:31:59 UTC
Blarg. initscripts-4.68-1, in the errata as we speak.

Comment 2 Bill Nottingham 1999-11-29 16:13:59 UTC
*** Bug 7285 has been marked as a duplicate of this bug. ****** Bug 7410 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.