Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7264 - ping -c fails to operate as expected
Summary: ping -c fails to operate as expected
Keywords:
Status: CLOSED DUPLICATE of bug 8724
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netkit-base
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-23 18:19 UTC by Kevin L. Mitchell
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-27 20:07:06 UTC


Attachments (Terms of Use)

Description Kevin L. Mitchell 1999-11-23 18:19:00 UTC
I frequently do ping -c 100 <hostname>; I expect it to send exactly
100 packets and tell me how many it got back, along with all the
statistics it reports.  However, the change apparently introduced
with RedHat 6.0 causes it to wait until it receives 100 responses,
which is exactly the opposite of every single ping program I have
ever used, and exactly the opposite of the way I want it to work.
There is no option to revert this blatently broken behavior, either.

Comment 1 kvaradhan 2000-01-13 18:44:59 UTC
Also: for all related ping -c bugs reported:


Redhat-6.1, the ping-ank.patch is broken (probably also the kuznetsov patch).
Fix the patch by hand, rebuild the rpm and reinstall.   The two lines to fix
are:


% rpm -ivh netkit-base-0.10-37.src.rpm
% cd /usr/src/redhat/SOURCES
% vi ping-ank.patch
	line 929:  Change +725,12 to +725,13
	line 937:  Remove the leading -
	line 1392: Change +1020,7 to +1020,8
	line 1397: Remove the leading -
	Save and exit
% cd /usr/src/rdhat/SPECS
% rpm -bb netkit-base.spec
% cd /usr/src/redhat/RPMS/i386
% rpm -Uvh --force netkit-base-0.10-37.i386.rpm

People who know this rpm stuff better, or redhat could issue a new patch to
this whole problem.


Kannan

Comment 2 Jeff Johnson 2000-01-27 20:07:59 UTC
*** This bug has been marked as a duplicate of 8724 ***


Note You need to log in before you can comment on or make changes to this bug.