Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7263 - "upgrade" from 6.0 to 6.1 downgrades a lot of packages
Summary: "upgrade" from 6.0 to 6.1 downgrades a lot of packages
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-23 18:12 UTC by Raul Acevedo
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-05 19:53:16 UTC


Attachments (Terms of Use)

Description Raul Acevedo 1999-11-23 18:12:31 UTC
I just tried "upgrading" from 6.0 to 6.1.

EVERY SINGLE PACKAGE THAT I HAD UPGRADED UNDER 6.0 GOT DOWNGRADED TO
WHATEVER 6.1 PROVDES.

October GNOME and E 0.16?  Gone, downgraded to 0.53 and 0.15.  My
Fortified version of Netscape 4.7?  Nope, back to 4.61.  Also my
i686 2.2.12 kernel, xscreensaver, ee, gftp (well, 2.0.6pre1 was
broken anyway), gtk+, xmms...

An upgrade to 6.1 should be just that: an UPGRADE.  What I got was
not an upgrade, but a replacement of all packages that were not
already installed.  That is called "an install on top of an existing
install", not an upgrade.  I couldn't do that with rpm on the
command line if I tried, yet the "install" does it without blinking.

Comment 1 Jay Turner 1999-11-29 16:56:59 UTC
This issue has been forwarded to a developer for further action.

Comment 2 Jay Turner 1999-11-30 13:23:59 UTC
*** Bug 6751 has been marked as a duplicate of this bug. ***

Comment 3 Jay Turner 1999-11-30 15:46:59 UTC
*** Bug 6539 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 2000-02-05 19:53:59 UTC
Fixed in the next installer release.


Note You need to log in before you can comment on or make changes to this bug.