Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7257 - RPM (from installer) doesn't always install man pages
Summary: RPM (from installer) doesn't always install man pages
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-23 16:57 UTC by Riley H Williams
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-22 19:34:22 UTC


Attachments (Terms of Use)

Description Riley H Williams 1999-11-23 16:57:16 UTC
Looking through one of my systems with `rpm -V` recently, I noticed that a
large number of the manpages were listed as mssing from packages that were
otherwise installed.

I had just done a fresh network install of RedHat 6.1 on a customer's
system (that had supposedly had all packages fully installed), so I went to
the said system and ran...

    for RPM in *.rpm ; do            \
        echo $RPM ;                  \
        rpm -V $RPM ;                \
        echo ;                       \
    done | less

...from the NFS mounted CD-ROM to check. Sure enough, certain packages had
not had the manpages installed.

I therefore ran...

    rpm -Uvh --force *.rpm

...and then reran the test, and this time, all manpages were installed.

I have to assume that this problem is something to do with the RedHat 6.1
installation system, as it appears that it's only during the installation
that the manpages are not installed, so I'm not sure whether reporting it
as an rpm bug is correct.

For reference, the following packages were amongst those for which the man
pages weren't installed:

        apache-1.3.9-4.i386.rpm
        cdrecord-1.8a29-2.i386.rpm
        genromfs-0.3-4.i386.rpm
        ipchains-1.3.9-3.i386.rpm
        kudzu-0.20-1.i386.rpm
        mkinitrd-2.3-1.i386.rpm
        rcs-5.7-10.i386.rpm
        wu-ftpd-2.5.0-9.i386.rpm

There were 10 packages in all that didn't, but I don't have details of the
other two packages to hand   8-(

Note particularly that the majority of packages DID have their manpages
installed, and it was just this small number of packages that for some
reason didn't have them installed.

Comment 1 Jeff Johnson 1999-12-15 17:48:59 UTC
This appears to be an installer problem since rpm from the command line
installs all man pages.

Comment 2 Riley H Williams 1999-12-15 19:33:59 UTC
Agreed, but it needs to be fixed either way. Any ideas?

Also, if it's not you I should report this to, who should it go to?

Comment 3 Jeff Johnson 1999-12-15 19:56:59 UTC
The bug is still reported. I merely changed the component to "installer" ...
Meanwhile, if you can find a reproducible test case from the rpm command line,
I'll be happy to fix the problem.


Note You need to log in before you can comment on or make changes to this bug.