Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 72512 - bash completion regression for directories buggy
Summary: bash completion regression for directories buggy
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: bash
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
: 76869 77535 77796 78037 84058 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-24 19:47 UTC by franz.sirl-kernel
Modified: 2007-04-18 16:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-27 09:01:07 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:140 normal SHIPPED_LIVE Updated bash packages fix several bugs 2003-06-23 04:00:00 UTC

Description franz.sirl-kernel 2002-08-24 19:47:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.1) Gecko/20020815

Description of problem:
Since a short while bash directory completion is broken, it doesn't attach the /
at the end anymore.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. # cd /usr
2. # ./bi<TAB>
3.
	

Actual Results:  This will give you:

"# ./bin "

Expected Results:  I expect (and it was this way until recently):

"# ./bin/"


Additional info:

Comment 1 Olivier Baudron 2002-08-25 13:36:13 UTC
This "feature" was introduced in bash-2.05b-alpha1.

In bash-2.05b/CHANGES:
i.  Fixed the command name completion code so a slash is no longer appended
    to a single match if there happens to be a directory with that name in
    $PWD.

I hope this will be reverted.

Comment 2 franz.sirl-kernel 2002-08-25 14:49:01 UTC
Ah, this brought me on the right track, somehow I thought this was a RH specific
bug, but it is generic. Searching Google revealed this patch on the bug-bash list:

http://www.geocrawler.com/lists/3/GNU/342/0/9185278/

I tried it and it works fine for me.

Comment 3 Tim Waugh 2002-10-17 09:35:54 UTC
Should be fixed in bash-2.05b-6.

Comment 4 Tim Waugh 2002-11-07 14:15:05 UTC
*** Bug 76869 has been marked as a duplicate of this bug. ***

Comment 5 Tim Waugh 2002-11-08 17:57:24 UTC
*** Bug 77535 has been marked as a duplicate of this bug. ***

Comment 6 Derek Price 2002-11-08 19:14:04 UTC
If you used the patch Franz pointed to, this will still be broken.  Thanks to
Paul Jarc <prj@po.cwru.edu>:

Derek Robert Price <derek@ximbiot.com> wrote:

> Tab completion now inserts spaces after directory names rather than slashes
> to allow for further path specification.
>
> Was this an intentional change or a bug?


It's a bug, partially fixed by patch bash205b-003.  This patch fixes
cases that start with "~", ".", or "/".  Other cases, like
foo/bar<TAB> without a leading "./", still get a space appended.


paul


Comment 7 Tim Waugh 2002-11-10 12:41:26 UTC
Confirmed.

Comment 8 Ben Levenson 2002-11-14 01:10:12 UTC
*** Bug 77796 has been marked as a duplicate of this bug. ***

Comment 9 Tim Waugh 2002-11-14 08:43:41 UTC
*** Bug 77796 has been marked as a duplicate of this bug. ***

Comment 10 Tim Waugh 2002-11-19 09:46:21 UTC
*** Bug 78037 has been marked as a duplicate of this bug. ***

Comment 11 Miloslav Trmac 2003-01-07 14:05:36 UTC
Still bronken in Phoebe.

Comment 12 Tim Waugh 2003-01-27 09:01:07 UTC
Please try 2.05b-16, which will shortly appear in rawhide.

Comment 13 Tim Waugh 2003-02-11 17:46:45 UTC
*** Bug 84058 has been marked as a duplicate of this bug. ***

Comment 14 Tim Waugh 2003-06-23 14:52:14 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-140.html


Comment 15 Tobias Polzin 2005-07-01 17:28:41 UTC
I wonder why this bug is closed, if one variant of it (see comment #6)

# subdir/subd[TAB]

# subdir/subdir[SPACE]_

instead of

# subdir/subdir/_

is still present (at least in 2.05b-r9)

Tobias

Comment 16 Tobias Polzin 2005-12-01 12:09:58 UTC
In 3.00.16 it seems to be fixed.
Tobias




Note You need to log in before you can comment on or make changes to this bug.