Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 724017 - Missing dictionaries
Summary: Missing dictionaries
Keywords:
Status: CLOSED DUPLICATE of bug 590700
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: aspell
Version: 6.1
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Peter Schiffer
QA Contact: i18n Engineering List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-21 17:48 UTC by Shing-Shong Shei
Modified: 2012-08-06 20:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-02 13:26:29 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Shing-Shong Shei 2011-07-21 17:48:31 UTC
Description of problem:
No dictionaries bundled with aspell packages

Version-Release number of selected component (if applicable):
aspell-0.60.6-12.el6.x86_64

How reproducible:
ispell -a

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Error: No word lists can be found for the language "en_US".

Expected results:
# aspell -a
@(#) International Ispell Version 3.1.20 (but really Aspell 0.60.3)

Additional info:
Fix it by installing aspell-en from EPEL.

Comment 2 RHEL Product and Program Management 2011-07-21 18:19:20 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 Shing-Shong Shei 2011-07-21 18:28:29 UTC
Well, we have been using RHEL for years and it always bundled with dictionaries for aspell.  For example, on RHEL 5# yum list aspell\*
Loaded plugins: aliases, changelog, dellsysid, downloadonly, fastestmirror, filter-data, keys, kmod, list-data, protect-packages,
              : protectbase, rhnplugin, security, tmprepo, verify, versionlock
Loading mirror speeds from cached hostfile
 * dell-community: linux.dell.com
csci-local                                                                                                  | 1.1 kB     00:00     
http://linux.dell.com/repo/community//content/el5Client-i386/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.    
rhel-i386-client-5                                                                                          | 1.3 kB     00:00     
rhel-i386-client-supplementary-5                                                                            | 1.3 kB     00:00     
rhel-i386-client-workstation-5                                                                              | 1.3 kB     00:00     
rhn-tools-rhel-i386-client-5                                                                                | 1.1 kB     00:00     
0 packages excluded due to repository protections
Reading version lock configuration
Installed Packages
aspell.i386                                              12:0.60.3-7.1                                           installed         
aspell-devel.i386                                        12:0.60.3-7.1                                           installed         
aspell-en.i386                                           50:6.0-2.1                                              installed         
Available Packages
aspell-af.i386                                           50:0.50-4.2.2                                           rhel-i386-client-5
aspell-bg.i386                                           50:0.50-11.2.2                                          rhel-i386-client-5
aspell-br.i386                                           50:0.50-4.2.2                                           rhel-i386-client-5
aspell-ca.i386                                           50:0.50-4.2.2                                           rhel-i386-client-5
aspell-cs.i386                                           50:0.51-3.2.2                                           rhel-i386-client-5
aspell-cy.i386                                           50:0.50-4.2.2                                           rhel-i386-client-5
aspell-da.i386                                           50:0.50-12.2.2                                          rhel-i386-client-5
aspell-de.i386                                           50:0.50-11.2.2                                          rhel-i386-client-5
aspell-el.i386                                           50:0.50-4.2.2                                           rhel-i386-client-5
aspell-es.i386                                           50:0.50-13.2.2                                          rhel-i386-client-5
aspell-fo.i386                                           50:0.51-4.2.2                                           rhel-i386-client-5
aspell-fr.i386                                           50:0.50-9.2.2                                           rhel-i386-client-5
aspell-ga.i386                                           50:0.50-4.2.2                                           rhel-i386-client-5
aspell-gd.i386                                           50:0.50-4.2.2                                           rhel-i386-client-5
aspell-gl.i386                                           50:0.50-4.2.2                                           rhel-i386-client-5
aspell-hr.i386                                           50:0.51-4.2.2                                           rhel-i386-client-5
aspell-id.i386                                           50:0.50.1-4.2.2                                         rhel-i386-client-5
aspell-is.i386                                           50:0.51.1-2.2.2                                         rhel-i386-client-5
aspell-it.i386                                           50:0.53-4.2.1                                           rhel-i386-client-5
aspell-nl.i386                                           51:0.1e-2.el5                                           rhel-i386-client-5
aspell-no.i386                                           50:0.50.1-9.2.2                                         rhel-i386-client-5
aspell-pl.i386                                           50:0.51-5.2.2                                           rhel-i386-client-5
aspell-pt.i386                                           50:0.50-10.2.2                                          rhel-i386-client-5
aspell-ru.i386                                           50:0.99f7-2.2.2                                         rhel-i386-client-5
aspell-sl.i386                                           50:0.50-1.2.1                                           rhel-i386-client-5
aspell-sr.i386                                           50:0.02-1.2.1                                           rhel-i386-client-5
aspell-sv.i386                                           50:0.51-1.2.1                                           rhel-i386-client-5

But on RHEL 6, it's:

# yum list aspell\*
Loaded plugins: aliases, auto-update-debuginfo, changelog, downloadonly, fastestmirror, filter-data, fs-snapshot, kabi, keys, list-data,
              : merge-conf, post-transaction-actions, presto, priorities, product-id, protectbase, ps, refresh-packagekit, remove-with-
              : leaves, rhnplugin, rpm-warm-cache, security, show-leaves, subscription-manager, tmprepo, tsflags, upgrade-helper,
              : verify, versionlock
Updating Red Hat repositories.
Loading support for Red Hat kernel ABI
Loading mirror speeds from cached hostfile
0 packages excluded due to repository protections
Installed Packages
aspell.x86_64                             12:0.60.6-12.el6                       @anaconda-RedHatEnterpriseLinux-201009221801.x86_64/6.0
aspell-devel.x86_64                       12:0.60.6-12.el6                       @rhel-x86_64-workstation-optional-6                    
aspell-en.x86_64                          50:6.0-11.el6                          @epel                                                  
Available Packages
aspell.i686                               12:0.60.6-12.el6                       rhel-x86_64-workstation-6                              
aspell-devel.i686                         12:0.60.6-12.el6                       rhel-x86_64-workstation-optional-6                     

An aspell without any bundled dictionaries is USELESS.  I view this as an oversight of RHEL 6.

Comment 4 Peter Schiffer 2011-11-02 13:26:29 UTC
aspell package was replaced by hunspell in RHEL 6. See:

# yum list hunspell\*

*** This bug has been marked as a duplicate of bug 590700 ***


Note You need to log in before you can comment on or make changes to this bug.