Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7173 - nfs mounting isn't working
Summary: nfs mounting isn't working
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: knfsd
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-20 12:44 UTC by andy
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-06 19:52:13 UTC


Attachments (Terms of Use)

Description andy 1999-11-20 12:44:50 UTC
I can't see why NFS doesn't work, so I'm reporting a bug. (Sorry).

<From the Server>

root@neuromancer /sbin]# /usr/sbin/exportfs
wintermute.bullgod.co.uk:/data
		<world>
wintermute.bullgod.co.uk:/data
		<world>
zen.bullgod.co.uk:/data
		<world>
zen.bullgod.co.uk:/data
		<world>
[root@neuromancer /sbin]# /usr/sbin/showmount -e
Export list for neuromancer:
zen.bullgod.co.uk:/data        (everyone)
wintermute.bullgod.co.uk:/data (everyone)

The client (wintermute) attempts to mount neuromancer:/data on /data:
[andy@neuromancer andy]$ rlogin wintermute
Last login: Sat Nov 20 00:06:13 on :0
$ mount /data/
mount: neuromancer:/data failed, reason given by server: Permission denied

[root@neuromancer /sbin]# tail -4 /var/log/messages
Nov 20 12:28:47 neuromancer nfs: rpc.mountd startup succeeded
Nov 20 12:28:47 neuromancer kernel: Installing knfsd (copyright (C) 1996
okir@monad.swb.de).
Nov 20 12:28:48 neuromancer nfs: rpc.nfsd startup succeeded
Nov 20 12:34:51 neuromancer mountd[1504]: refused mount request from
wintermute.bullgod.co.uk for /data (/): no export entry

Communication between wintermute & neuromancer is working enough for
X to work both ways. rpc.mountd / knfsd all appear to be fine, so why
the Permission denied and mount refused?

AMP

Comment 1 cavanaug 1999-12-07 08:58:59 UTC
I am seeing the same thing on 2 machine here.  Except for me the problem goes
away if I specify each host by name in /etc/hosts.  It does not work for
something like @netgroup or *.wlv.hp.com.

I am totally confused.  I have 6 boxes identically configured.  I see this
problem on 2 of them but the other 4 work fine.  Help!!!!

--John Cavanaugh

Comment 2 cavanaug 1999-12-07 08:59:59 UTC
Oops that should have been /etc/exports...  --John C

Comment 3 Need Real Name 2000-01-05 22:48:59 UTC
I have the same terrible problem here. It makes RH61 useless and I'm going to
downgrade again to RH52 :-( I really don't understand that bugs in such an
important service as NFS doesn't get the highest priority at RH :-(((

Maybe this small report will help a bit:

My /etc/exports:
/       asterix(rw,no_root_squash)
/       idefix(rw,no_root_squash)
/       obelix(rw,no_root_squash)
/       abraracourcix(rw,no_root_squash)
/       panoramix(rw,no_root_squash)

Entering:
"exportfs -av"
gives:

exporting panoramix:/
exporting abraracourcix:/
exporting obelix:/
exporting idefix:/
exporting asterix:/

So far OK (except that locally mounted directories aren't accessible through
NFS!!!)

adding the line
/home/windows    asterix(rw) abraracourcix(rw) idefix(rw)
to /etc/exports (/home/windows/ is on the same partition as /) gives:

"exportfs -av"
exporting idefix:/home/windows
idefix:/home/windows: Invalid argument
exporting abraracourcix:/home/windows
abraracourcix:/home/windows: Invalid argument
exporting asterix:/home/windows
asterix:/home/windows: Invalid argument
exporting panoramix:/
exporting abraracourcix:/
exporting obelix:/
exporting idefix:/
exporting asterix:/

An /etc/exports with:
/	192.168.100.0/24(rw,no_root_squash)
gives NFS connection on some machines, but others get "Permission denied" while
the station that sees "permission denied" appears in /var/lib/nfs/xtab. When
changing something an "/etc/rc.d/init.d/nfs stop-start" is absolutely necessary.

When a workstation is unmounted, its entry stays in the xtab file. I understood
from the docs that the line should be removed in that case.

The only thing that seems to "work" is mentioning all workstations one by one in
/etc/exports. Two or more mountpoints on for the same workstation is not
possible.

I discovered this bug after a few days, while the kNFSd service was one of the
first services that I installed. If this bug had been present from the beginning
I would certainly have remarked it the first day. During the first few days I
installed all sorts of services on that machine (maybe a file or a lib
overwritten?). Kernels: 2.2.12-20 (original and modified) and 2.2.13, now I
going to compile 2.2.14 that came out yesterdaynight. If that resolves the
problem you'll certainly hear from me. Maybe it would be an idea to make some
RH61-rpm's for the RH52 version of the nfs programs? Please find a solution to
this problem asap, the knfsd isn't even an alpha version (with respect for the
one(s) who work(s) on it of course).

Workstations: RH52 and RH61. All i486/i586/i686. Installed from original release
and upgraded with all rpm's from ftp-server.

Richard Lucassen.

Btw: I have a few files here if somebody is interested:
"strace exportfs -av 1>exports.1 2>exports.2" I have a very 'stable' buggy
version here.

Comment 4 Need Real Name 2000-01-06 19:28:59 UTC
I downloaded "nfs-server-2.2beta47-1.src.rpm" from the update-directory of RH52,
rebuilt it and installed it. Until now (knock, knock on wood) this seems to work
fine. Please mail me if I do something stupid (I'm not a Linux expert).

Richard.

Comment 5 Cristian Gafton 2000-01-06 19:52:59 UTC
You need to export each mount point separately. Ie if / and /data are on
different partitions, you need to list both / and /data in /etc/exports.

Comment 6 Need Real Name 2000-01-06 20:51:59 UTC
Yes ok, I understand that (it seems that this is the original way of mounting
directories, I heard this morning), and I can live with that. But the problem is
still the same: "Invalid argument" as mentioned above. knfsd doesn't let a
client mount two directories on the exporting server. "Permission denied" is the
answer that the client gets, while there should be no reason for a denial. This
bugreport starts with this "permission denied" story. In that case an "exportfs
-av" on the server gives:
NFS_server:'/exported_dir': Invalid argument

This is really not normal behaviour.

If I enter in /etc/exports:
/    192.168.100.0/24(rw)
some machines in the 192.168.100.* network can mount the exported directory,
some cannot. They get "permission denied", even though the /var/lib/nfs/xtab
indicates that everything is ok.

I admit that I regularly do and say stupid things and I still consider myself as
a newbee but IMHO this is really a bug and not a feature ;-)

Richard.


Note You need to log in before you can comment on or make changes to this bug.