Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7165 - Niggles in top.
Summary: Niggles in top.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: procps
Version: 4.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
: 7166 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-20 01:17 UTC by dwmalone
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-22 20:57:52 UTC


Attachments (Terms of Use)

Description dwmalone 1999-11-20 01:17:48 UTC
Top seems to have behavior unlike any other version of top I've
used. I've one bug and one feature request.

1) Running top through rsh bogusly reports that TERM is set to
VT100 - I note that strings shows that VT100 is a string in top.
Other versions of top seem to show 24 lines of output in the
situation where they are not connected to a tty. (Note, $TERM
definitely doesn't contain VT100):
1:21:walton 71% rsh graves top
top: Unknown terminal "VT100" in $TERM
1:21:walton 72% rsh graves echo $TERM
xterm

2) When sending a signal top only allows you to give the number
of one process, it would be nice to be able to give a list. Also
it would be nice if you could give the signal number on the PID
line, so you can do something like "k -9 3927 7320 9327".

Comment 1 Bill Nottingham 1999-11-22 15:57:59 UTC
*** Bug 7166 has been marked as a duplicate of this bug. ***

Comment 2 Michael K. Johnson 1999-11-22 20:57:59 UTC
TERM is only set to VT100 if it is unset.  It's a least-common-denominator
guess, and is a feature, not a bug.  Set TERM and the problem will go away.

Regarding item 2, feel free to send a patch to procps-bugs@redhat.com for
consideration.  While the idea seems reasonable to me at first thought,
I don't know if/when I'd get around to implementing it.

Comment 3 Chris Siebenmann 1999-11-23 00:15:59 UTC
The traditional (and useful) behavior of top when TERM is unset
is to do what one would now get with 'top b n 1' (which are,
unfortunately, modern-Linux-top specific arguments, which makes
them hard to use in portable shell scripts and in working habits
which aren't Linux-exclusive).


Note You need to log in before you can comment on or make changes to this bug.