Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 716 - bootable CD-ROM hangs system if no floppy drive present
Summary: bootable CD-ROM hangs system if no floppy drive present
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 5.2
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-06 19:58 UTC by matt.brown
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-01-07 22:36:56 UTC


Attachments (Terms of Use)

Description matt.brown 1999-01-06 19:58:20 UTC
(I think this is a bug!)

With my PowerEdge2300 I cannot boot from the RedHat 5.2
CDROM unless my floppy drive is installed and enabled. I'm
not booting from floppy and there is no diskette in the
drive. The system hangs just after it "discovers" the
bootable media in the cdrom drive. Normally, the system
would continue discovering devices on my other SCSI bus
after discovering the bootable media. With the floppy (and
no diskette in the drive!) I boot fine. Without the floppy I
hang.

I've tried enabling/disabling floppy controller in the CMOS
setup.

The bootable WinNT cdrom does not hang the system with or
without the floppy. It gets booted up and starts installing.
(I tried the WinNT cdrom to try to isolate the problem to
RedHat or my hardware. I do not dual-boot WinNT. This
machine is exclusively Linux.)

This is not a severe problem-I removed the floppy drive,
which I don't need, to make room for a Zip drive. I now have
the floppy mounted internally as a workaround.

Comment 1 David Lawrence 1999-01-06 21:59:59 UTC
This has been assigned to our hardware certification person for
further review.

Comment 2 Doug Ledford 1999-01-07 22:36:59 UTC
The problem is not actually a Red Hat 5.2 problem.  It has been
confirmed from Dell and Adaptec that the problem is a BIOS bug.
Specifically, when the Adaptec BIOS attempts to move Drive A to Drive
B and no Drive A exists, then it crashes the machine.  The Windows NT
CD-ROM does not cause this problem because it uses the Torino CD-ROM
extension for booting instead of the emulated floppy extension that
Red Hat uses.

No new BIOS has been made for the machine at this time, and the
current solution is that once the system is installed, don't boot from
the Red Hat 5.2 CD-ROM and you can do what-ever you wish with the
floppy.  If you must be able to boot from CD-ROM that uses the floppy
style boot extension, then further action will be needed.  In either
case, it isn't really a Red Hat problem, it specifically is a Dell
problem, so this trouble ticket will be closed out.


Note You need to log in before you can comment on or make changes to this bug.