Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 71565 - `DOS' renamed / replaced by `Windows' quite some time ago
Summary: `DOS' renamed / replaced by `Windows' quite some time ago
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-15 09:01 UTC by Mike MacCana
Modified: 2007-04-18 16:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-09-25 21:55:09 UTC


Attachments (Terms of Use)

Description Mike MacCana 2002-08-15 09:01:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
Lilo (and lilely grub) detects existing Operating Systems installed on fat32
partitions and adds the label `DOS'. The `DOS' Operating System was apparently
renamed `Windows' some time ago. Really, its true! :)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Red Hat on a machine with another Oeprating System that lives on a
vfat partition
2.Look at the label lilo gives that OS

	

Actual Results:  It says `DOS'. You're using Windows. Which these days is a
different Operating System from DOS. 

Expected Results:  It should say `Windows'. 

Additional info:

Apparently this `Windows' is an Operating System like Red Hat Linux is! It's
like `DOS', but newer, and made by a company called `Microsoft'. I know it
sounds fanciful, but apparently people that use this `Windows' find the label
`DOS' kinda amusing in 2002. :)
I may have reported this bug before, but I can't find it in Bugzilla and its
still there. Sorry if this is a duplicate.

Comment 1 Barry K. Nathan 2002-08-16 07:37:51 UTC
Also, most DOS installations which are capable of reading/writing FAT32
partitions identify themselves as some form of "Windows" in response to the VER
command.

Comment 2 Taco Witte 2002-08-16 18:30:38 UTC
For the note: Grub has indeed the same problem.

Comment 3 Barry K. Nathan 2002-08-17 06:55:51 UTC
Oh, I just noticed that the component listed in this bug is LILO... I might be
incorrect, but wouldn't anaconda be more appropriate? As far as I can tell, it's
anaconda that's deciding to add the "DOS" label.

Comment 4 Warren Togami 2002-08-17 08:50:17 UTC
Please change component to Anaconda.

Comment 5 Mike MacCana 2002-08-17 09:05:59 UTC
Changed accordingly.

Comment 6 Warren Togami 2002-08-18 08:35:02 UTC
Can this be changed to say something among the following labels, perhaps with
some intelligent detection:

Windows/DOS
Windows (FAT32)
Windows/DOS (FAT16)
Windows (NTFS)

Comment 7 Jeremy Katz 2002-08-18 17:17:27 UTC
Can't find the older bug to dupe this against, but the short speech is that
Windows is a trademark of Microsoft and therefore we can't do it.

Comment 8 Mike MacCana 2002-08-19 09:56:33 UTC
Fair enough, but here's two options that avoid this problem and fix the bug:   
 
* `Win32' doesn't seem to be a trademark and is an accurate description of the  
OS.    
 
* With a modern 640 x 480 Lilo boot message, Red Hat could easily fit an  
unobtrusive `All trademarks are the property of their respective owners' in a  
small all-cap font.  


Comment 9 Warren Togami 2002-08-19 11:51:03 UTC
I'm in agreement regarding "Win32".  Any possibilty here?  Just anything but
"DOS".  It is misleading these days and possibly confusing to new users.

Comment 10 Jeremy Katz 2002-08-22 03:41:46 UTC
Sorry, not changing this this late... it has too many effects on documentation
and the like

Comment 11 Jeremy Katz 2003-09-25 21:55:09 UTC
Done


Note You need to log in before you can comment on or make changes to this bug.