Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7154 - BUG IN DYNAMIC LINKER ld.so: dl-runtime.c: 67
Summary: BUG IN DYNAMIC LINKER ld.so: dl-runtime.c: 67
Keywords:
Status: CLOSED DUPLICATE of bug 6685
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-19 20:49 UTC by cbenson
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-05 00:06:33 UTC


Attachments (Terms of Use)

Description cbenson 1999-11-19 20:49:34 UTC
Fresh install of RH v6.1 on Dell OptiPlex GXMT 5133 (1 x 133 MHz Pentium).
External 4.3 GB Fujitsu SCSI disk, NT on internal IDE disk.

Tried various installs (Gnome workstation, variations of Custom) that work
to different degrees, but all report

BUG IN DYNAMIC LINKER ld.so: dl-runtime.c: 67: fixup: Assertion
'((reloc->r_info) & 0xff) ==7' failed!

This message repeats *a lot*. Custom install with most everything selected
results in being unable to login as root in terminal session *at all*.

"Gnome workstation" install resulted in fewest errors, but Gnome itself was
missing most of the fonts. Installing 100dpi fonts (for 21" high-res)
helped not at all. "BUG IN DYNAMIC LINKER" error still occurs.

Tried different SCSI disk, with same results, so it's not a disk error.

Can boot "linux single" successfully, and look at log files.

Comment 1 Cristian Gafton 2000-01-05 00:05:59 UTC
Can you find out what binary is producing that message? Is it the X server or
something else? Can you boot in runlevel 3 by default?

Comment 2 Cristian Gafton 2000-01-05 00:06:59 UTC
*** This bug has been marked as a duplicate of 6685 ***


Note You need to log in before you can comment on or make changes to this bug.