Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7115 - xterm keymap hosed going from RH6.1/0 -> AIX
Summary: xterm keymap hosed going from RH6.1/0 -> AIX
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xterm-color
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-18 20:03 UTC by dfrussell
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-24 21:28:00 UTC


Attachments (Terms of Use)

Description dfrussell 1999-11-18 20:03:29 UTC
1. Open an xterm under RH 6.0 or 6.1
2. rsh to AIX 4
3. Run smitty with TERM=xterm
4. Press [F3] -- function key ignored.

1. rsh to AIX 4 from RH 6
2. run xterm from AIX with DISPLAY set to RH 6.
3. run smitty on xterm from aix system on RH 6.
4. Press [F3] -- function key works

I decompiled and compared termcaps for xterm on both systems
they are identical.

Only possible gotcha is I have ssh installed.... it should be used under
both of the above cases, though.

Any clue as to what the problem is?  Looks like the xterm implementation
on RH 6.1 is hosing the key map somehow.

Comment 1 Preston Brown 2000-01-24 21:28:59 UTC
this should be fixed in the next release.


Note You need to log in before you can comment on or make changes to this bug.