Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 71146 (xftcache) - postinstall requires xftcache
Summary: postinstall requires xftcache
Keywords:
Status: CLOSED WONTFIX
Alias: xftcache
Product: Red Hat Raw Hide
Classification: Retired
Component: ttfonts
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: David Lawrence
URL:
Whiteboard:
: 71493 78708 83722 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-09 09:57 UTC by Kjetil T. Homme
Modified: 2007-04-18 16:45 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-08-31 19:10:11 UTC


Attachments (Terms of Use)

Description Kjetil T. Homme 2002-08-09 09:57:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020712

Description of problem:
while upgrading to latest Raw Hide, I got this error message:

 159:XFree86                ########################################### [ 72%]
/var/tmp/rpm-tmp.96733: line 1: xftcache: command not found


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. remove the package containing xftcache (I don't know which that is yet :-)
2. upgrade XFree86 to 4.2.0-60.1
3.
	

Additional info:

Comment 1 Mike A. Harris 2002-08-09 14:02:05 UTC
xftcache was a part of XFree86 in previous distribution releases.
It no longer exists anymore as it is replaced by fontconfig/fc-cache.

Whatever package is using xftcache in it's rpm scripts/triggers should
be using fc-cache instead.  It isn't XFree86 though, so I'm reassigning
this to fontconfig.

Comment 2 Owen Taylor 2002-08-09 15:21:45 UTC
rpm -q --triggeredby XFree86 

seems to indicate the culprit is ttfonts. But ttfonts has been
removed from the distribution, so the we can't fix its triggers.

My best idea is to make something else obsolete ttfonts ... but
what? fontconfig? XFree86? urw-fonts?


Comment 3 Jeremy Katz 2002-08-10 20:36:44 UTC
Did the fonts completely go away or are they replaced by fonts from somewhere
else?  We really don't want to obsolete them because then if people have a
specific reason to want them, we'll constantly be removing them.

Comment 4 Owen Taylor 2002-08-12 20:00:22 UTC
They completely went away, because they were:

 a) Awful fonts
 b) Legally questionable (they were removed from OpenOffice.org CVS)

I suppose we could make fontconfig provide a symlink from
xftcache to fc-cache, but I really would hate to do this 
because we would *never* be able to remove that xftcache symlink,
and it would just cause continuing confusion.

(Yet more evidence that "triggers suck")

Comment 5 Mike A. Harris 2002-08-13 00:46:46 UTC
I agree with Owen.  We shoudn't have a symlink to xftcache IMHO,
as it could cause future problems.  It would have bad assumptions
at best.

Personally, I think this problem can be closed as CANTFIX as it is
an rpm trigger problem, and as Owen says, triggers suck.

Too bad people are jumping to use triggers more and more to solve
problems.  ;o(

Comment 6 Mike A. Harris 2002-08-14 12:18:14 UTC
*** Bug 71493 has been marked as a duplicate of this bug. ***

Comment 7 Mike A. Harris 2002-08-14 12:32:23 UTC
Since we can't fix ttfonts because the problem only occurs with an
already installed version and we can't change that, all we can do
is thrash anyone severely who adds triggers to rpm packages without
thoroughly testing them.  ;o)

The xftcache symlink is a bad idea IMHO.  Perhaps I should include
an xftcache shell script which does nothing.

Comment 8 Kjetil T. Homme 2002-08-14 15:09:03 UTC
interesting discussion.  it seems to me that the problem is a missing dependency
in ttfonts (for "/usr/bin/xftcache"), not the trigger per se.  with such a
dependency, apt-rpm would have suggested I remove ttfonts as upgrading XFree86
has higher priority.  that's a moot point, though, since ttfonts can't be fixed.
 another point is that care has to be taken when removing a package.  in this
case, perhaps a new version sans triggers should have been shipped before removal.

anyway, I concur with the idea of a dummy shell script, at least through the 7.x
series.  it should emit a warning about its obsoleteness, though, and perhaps
even name ttfonts as an obsolete package so that it is clear that it's not the
XFree86 RPM which is buggy.

another option is to make an RPM (compat-rh7x ?) with sundry compatibility
fixes, which amongst other things Conflicts: ttfonts.

Comment 9 Petri T. Koistinen 2002-08-31 19:10:04 UTC
Will you mark this as DEFERRED or WONTFIX?

Comment 10 Mike A. Harris 2002-09-01 07:45:39 UTC
Marking as WONTFIX

Comment 11 Mike A. Harris 2003-02-14 07:45:34 UTC
*** Bug 83722 has been marked as a duplicate of this bug. ***

Comment 12 Mike A. Harris 2003-11-19 15:21:31 UTC
Adding bug alias "xftcache" to report for ease in closing duplicate
bug reports that occur every time there is a new OS release or
XFree86 update, because the ttfonts trigger will essentially
cause this problem to happen forever.   <sigh>

Comment 13 Mike A. Harris 2003-11-19 15:22:27 UTC
*** Bug 71402 has been marked as a duplicate of this bug. ***

Comment 14 Mike A. Harris 2003-11-19 15:25:29 UTC
*** Bug 78708 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.