Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7114 - xfs prevents fifth X server from starting
Summary: xfs prevents fifth X server from starting
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-18 19:55 UTC by James Manning
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-03 21:53:06 UTC


Attachments (Terms of Use)

Description James Manning 1999-11-18 19:55:20 UTC
Stock RH 6.1, XF86_SVGA server, gdm, as root (just to make sure it
wasn't perms)

from a text screen, startx -- :{1,2,3} all work fine, starting up
an X server on vt's {8,9,10} respectively.  doing the startx -- :4
to start a fifth server, the screen blanks like it's starting X, then
it dies and kicks back to the text vt, with the messages:

failed to set default font path 'unix/:-1'
Fatal server error:
could not open default font 'fixed'

Out of curiosity, I stop'd and start'd xfs and then :4 worked fine
(this will probably break fonts on :{0,1,2,3} though :)

I can't find anything in the xfs docs about a limitation to four
X servers, so I'm unsure of how to fix this.

This is on a user's machine (board designer) and he claims that the
capability to start 6 X sessions worked fine in RH 6.0 and only after
the 6.1 reinstall (fresh install, no upgrade) did it fail.

Comment 1 Alexandre Blanchette 2000-01-13 02:19:59 UTC
in /etc/X11/fs/config, change the line client-limit = 4 with the number of X
Sessions you want to have simultneously.

Comment 2 Preston Brown 2000-02-03 21:53:59 UTC
or change clone-self=off to clone-self=on.  This will be the new default in 6.2.


Note You need to log in before you can comment on or make changes to this bug.